aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xorg-util
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-03-15 08:49:48 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-03-15 08:49:48 +0100
commit3aec39dd6117e9112876c4b7d88c7324cb296c34 (patch)
treeb5508c38b8cdf958231165fbe951ddfb30b1411d /recipes/xorg-util
parente2c2c3d636045bf9b292b103a4f4fb0a4c16deab (diff)
downloadopenembedded-3aec39dd6117e9112876c4b7d88c7324cb296c34.tar.gz
xorg-util: used BPN in xorg-util-common
as per hrw's suggestion Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Conflicts: recipes/xorg-util/xorg-util-common.inc Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/xorg-util')
-rw-r--r--recipes/xorg-util/gccmakedep_1.0.2.bb2
-rw-r--r--recipes/xorg-util/imake_1.0.2.bb2
-rw-r--r--recipes/xorg-util/lndir_1.0.1.bb2
-rw-r--r--recipes/xorg-util/makedepend_1.0.2.bb2
-rw-r--r--recipes/xorg-util/util-macros_1.6.0.bb1
-rw-r--r--recipes/xorg-util/xorg-cf-files_1.0.3.bb2
-rw-r--r--recipes/xorg-util/xorg-util-common.inc10
7 files changed, 8 insertions, 13 deletions
diff --git a/recipes/xorg-util/gccmakedep_1.0.2.bb b/recipes/xorg-util/gccmakedep_1.0.2.bb
index 3abfa037a2..cb28a86703 100644
--- a/recipes/xorg-util/gccmakedep_1.0.2.bb
+++ b/recipes/xorg-util/gccmakedep_1.0.2.bb
@@ -3,5 +3,5 @@ require xorg-util-common.inc
DESCRIPTION = "create dependencies in makefiles using 'gcc -M'"
RDEPENDS = "gcc"
-PR = "r2"
+PR = "r3"
PE = "1"
diff --git a/recipes/xorg-util/imake_1.0.2.bb b/recipes/xorg-util/imake_1.0.2.bb
index deeb4477a1..b0eda35823 100644
--- a/recipes/xorg-util/imake_1.0.2.bb
+++ b/recipes/xorg-util/imake_1.0.2.bb
@@ -3,5 +3,5 @@ require xorg-util-common.inc
DESCRIPTION = "C preprocessor interface to the make utility"
RDEPENDS = "perl xproto"
-PR = "r1"
+PR = "r2"
PE = "1"
diff --git a/recipes/xorg-util/lndir_1.0.1.bb b/recipes/xorg-util/lndir_1.0.1.bb
index 34309a6487..fffc71034e 100644
--- a/recipes/xorg-util/lndir_1.0.1.bb
+++ b/recipes/xorg-util/lndir_1.0.1.bb
@@ -1,5 +1,5 @@
require xorg-util-common.inc
DESCRIPTION = "create a shadow directory of symbolic links to another directory tree"
-PR = "r1"
+PR = "r2"
PE = "1"
diff --git a/recipes/xorg-util/makedepend_1.0.2.bb b/recipes/xorg-util/makedepend_1.0.2.bb
index e998bba1b0..a7a2385506 100644
--- a/recipes/xorg-util/makedepend_1.0.2.bb
+++ b/recipes/xorg-util/makedepend_1.0.2.bb
@@ -2,5 +2,5 @@ require xorg-util-common.inc
DESCRIPTION = "create dependencies in makefiles"
DEPENDS = "xproto util-macros"
-PR = "r2"
+PR = "r3"
PE = "1"
diff --git a/recipes/xorg-util/util-macros_1.6.0.bb b/recipes/xorg-util/util-macros_1.6.0.bb
index 661eba4654..0fb42dc55f 100644
--- a/recipes/xorg-util/util-macros_1.6.0.bb
+++ b/recipes/xorg-util/util-macros_1.6.0.bb
@@ -1,6 +1,7 @@
require xorg-util-common.inc
DESCRIPTION = "X autotools macros"
+PR = "r1"
PE = "1"
ALLOW_EMPTY = "1"
diff --git a/recipes/xorg-util/xorg-cf-files_1.0.3.bb b/recipes/xorg-util/xorg-cf-files_1.0.3.bb
index 7c3fb8d7e9..3f0f4b3f06 100644
--- a/recipes/xorg-util/xorg-cf-files_1.0.3.bb
+++ b/recipes/xorg-util/xorg-cf-files_1.0.3.bb
@@ -2,7 +2,7 @@ require xorg-util-common.inc
DESCRIPTION = "X Window System CF files"
-PR = "r1"
+PR = "r2"
PE = "1"
FILES_${PN} += " /usr/lib/X11/config"
diff --git a/recipes/xorg-util/xorg-util-common.inc b/recipes/xorg-util/xorg-util-common.inc
index 998b37b3c0..b169d9ef58 100644
--- a/recipes/xorg-util/xorg-util-common.inc
+++ b/recipes/xorg-util/xorg-util-common.inc
@@ -2,14 +2,8 @@ HOMEPAGE = "http://www.x.org"
SECTION = "x11/utils"
LICENSE = "MIT-X"
-XORG_PN = "${PN}"
+SRC_URI = "${XORG_MIRROR}/individual/util/${BPN}-${PV}.tar.gz;name=archive"
-SRC_URI = "${XORG_MIRROR}/individual/util/${XORG_PN}-${PV}.tar.gz;name=archive"
-
-S = "${WORKDIR}/${XORG_PN}-${PV}"
+S = "${WORKDIR}/${BPN}-${PV}"
inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}