aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-08-10 18:20:50 +0400
committerRoman I Khimov <khimov@altell.ru>2010-09-23 09:49:28 +0400
commit67ab615dac83b0460fa1b88dfb11c72d7c93e259 (patch)
treeeac38500720f58e709b77ae26224cd7a5515e0c0 /recipes
parent9c8beee3e61f953accf5b080cfe1509ab497bfcc (diff)
downloadopenembedded-67ab615dac83b0460fa1b88dfb11c72d7c93e259.tar.gz
perl 5.10.1: PROVIDES libmodule-build-perl
perl 5.10.1 has Module::Build built-in and it's newer than what we have in libmodule-build-perl-native. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/perl/perl-native_5.10.1.bb6
-rw-r--r--recipes/perl/perl-rprovides_5.10.1.inc1
-rw-r--r--recipes/perl/perl_5.10.1.bb6
3 files changed, 11 insertions, 2 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 0e0854b6d1..b6e0bb56e1 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,12 +3,16 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r4"
+PR = "r5"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
DEFAULT_PREFERENCE = "-1"
+# 5.10.1 has this module built-in
+PROVIDES += "libmodule-build-perl-native"
+RPROVIDES_${PN} += "libmodule-build-perl-native"
+
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
diff --git a/recipes/perl/perl-rprovides_5.10.1.inc b/recipes/perl/perl-rprovides_5.10.1.inc
new file mode 100644
index 0000000000..9a648dbf2f
--- /dev/null
+++ b/recipes/perl/perl-rprovides_5.10.1.inc
@@ -0,0 +1 @@
+RPROVIDES_perl-module-module-build += "libmodule-build-perl"
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 50db49209f..8a0726ae55 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,10 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r12"
+PR = "r13"
+
+# 5.10.1 has Module::Build built-in
+PROVIDES += "libmodule-build-perl"
# Not tested enough
DEFAULT_PREFERENCE = "-1"
@@ -279,5 +282,6 @@ FILES_perl-module-unicore-name += "${datadir}/perl/${PV}/unicore"
require perl-rdepends_${PV}.inc
require perl-rprovides.inc
+require perl-rprovides_${PV}.inc
PARALLEL_MAKE = ""