aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-11-28 15:00:31 +0100
committerEric Bénard <eric@eukrea.com>2010-11-29 11:36:03 +0100
commitcb0419cc5fbf3ddf147d689e027a3fe83d368a3e (patch)
tree49c9afcd2005b28831b7dc83ee714aa87f6f9bc6 /recipes
parent4764ed351dcf832776e3012ea5a00e97685c4da0 (diff)
downloadopenembedded-cb0419cc5fbf3ddf147d689e027a3fe83d368a3e.tar.gz
add task-qt4-x11 and qt4-x11 base & demo images
these are images integrating qt4-x11-free librarie and its demo applications running using Xorg. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/images/qt4-x11-base-image.bb30
-rw-r--r--recipes/images/qt4-x11-demo-image.bb7
-rw-r--r--recipes/tasks/task-qt4-x11.bb46
3 files changed, 83 insertions, 0 deletions
diff --git a/recipes/images/qt4-x11-base-image.bb b/recipes/images/qt4-x11-base-image.bb
new file mode 100644
index 0000000000..83a1d34c64
--- /dev/null
+++ b/recipes/images/qt4-x11-base-image.bb
@@ -0,0 +1,30 @@
+require micro-base-image.bb
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-tslib \
+ xf86-video-fbdev "
+
+DEPENDS += "task-qt4-x11"
+
+RDEPENDS_${PN} += " \
+ task-qt4-x11-base \
+ task-qt4-x11-qwt \
+ "
+
+IMAGE_INSTALL += "\
+ initscripts \
+ kernel-modules \
+ gdbserver \
+ strace \
+ module-init-tools \
+ task-qt4-x11-base \
+ task-qt4-x11-qwt \
+ ${TOUCH} \
+ pointercal \
+ ${XSERVER} \
+ ttf-liberation-sans ttf-liberation-serif ttf-liberation-mono \
+ xauth xhost xset xrandr \
+"
diff --git a/recipes/images/qt4-x11-demo-image.bb b/recipes/images/qt4-x11-demo-image.bb
new file mode 100644
index 0000000000..8d14dc144c
--- /dev/null
+++ b/recipes/images/qt4-x11-demo-image.bb
@@ -0,0 +1,7 @@
+require qt4-x11-base-image.bb
+
+IMAGE_INSTALL += "\
+ qt4-demos qt4-examples qt-demo-init \
+ qt4-assistant \
+ qwt-examples \
+"
diff --git a/recipes/tasks/task-qt4-x11.bb b/recipes/tasks/task-qt4-x11.bb
new file mode 100644
index 0000000000..e2e1fe2166
--- /dev/null
+++ b/recipes/tasks/task-qt4-x11.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "QT4-X11 base Image Feed"
+PR = "r0"
+LICENSE = "MIT"
+
+inherit task
+
+PACKAGES += " \
+ ${PN}-base \
+ ${PN}-qwt \
+"
+
+RDEPENDS_${PN}-base = " \
+ qt4-x11-free \
+ libqt3support4 \
+ libqtclucene4 \
+ libqtcore4 \
+ libqtdbus4 \
+ libqtgui4 \
+ libqthelp4 \
+ libqtmultimedia4 \
+ libqtnetwork4 \
+ libqtscript4 \
+ libqtscripttools4 \
+ libqtsql4 \
+ libqtsvg4 \
+ libqttest4 \
+ libqtwebkit4 \
+ libqtxml4 \
+ libqtxmlpatterns4 \
+ qt4-fonts \
+ qt4-plugin-iconengine-svgicon \
+ qt4-plugin-imageformat-gif \
+ qt4-plugin-imageformat-ico \
+ qt4-plugin-imageformat-jpeg \
+ qt4-plugin-imageformat-mng \
+ qt4-plugin-imageformat-svg \
+ qt4-plugin-imageformat-tiff \
+ qt4-plugin-phonon-backend-gstreamer \
+ qt4-plugin-script-dbus \
+ qt4-plugin-sqldriver-sqlite2 \
+ qt4-plugin-sqldriver-sqlite \
+"
+
+RDEPENDS_${PN}-qwt = "\
+ qwt \
+" \ No newline at end of file