aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-01-18 15:33:10 -0800
committerKhem Raj <raj.khem@gmail.com>2011-01-18 15:33:52 -0800
commitccf1f883285e707e6b3887a8107f25530b1ec802 (patch)
treeb44bde0b7437d9ddb9733ded5a21132b08821513 /recipes
parent2a31f77a175b58d9ab52f8af40029a5f0fae5774 (diff)
downloadopenembedded-ccf1f883285e707e6b3887a8107f25530b1ec802.tar.gz
perl: Fix build for linux-uclibcspe targets
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/perl/perl_5.10.1.bb4
-rw-r--r--recipes/perl/perl_5.8.8.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 33ddffef78..8e6d1d6da7 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r20"
+PR = "r21"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -125,7 +125,7 @@ do_configure() {
done
# Fixups for uclibc
- if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" -o "${TARGET_OS}" = "linux-uclibcspe" ]; then
sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
-e "s,\(d_futimes=\)'define',\1'undef',g" \
-e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 0deaf39038..da40972c93 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPLv1+"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r38"
+PR = "r39"
# Major part of version
PVM = "5.8"
@@ -79,7 +79,7 @@ do_configure() {
done
# Fixups for uclibc
- if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
+ if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" -o "${TARGET_OS}" = "linux-uclibcspe" ]; then
sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
-e "s,\(d_futimes=\)'define',\1'undef',g" \
-e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \