aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/cpan-base.bbclass2
-rw-r--r--recipes/perl/perl-native_5.8.8.bb2
-rw-r--r--recipes/perl/perl.inc4
-rw-r--r--recipes/perl/perl_5.8.8.bb4
4 files changed, 6 insertions, 6 deletions
diff --git a/classes/cpan-base.bbclass b/classes/cpan-base.bbclass
index 394539daba..cc0d11e515 100644
--- a/classes/cpan-base.bbclass
+++ b/classes/cpan-base.bbclass
@@ -10,7 +10,7 @@ RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
# Determine the staged version of perl from the perl configuration file
def get_perl_version(d):
import os, bb, re
- cfg = bb.data.expand('${STAGING_DIR)/${HOST_SYS}/perl/config.sh', d)
+ cfg = bb.data.expand('${STAGING_DIR}/${HOST_SYS}/perl/config.sh', d)
try:
f = open(cfg, 'r')
except IOError:
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index cac474edc4..ba05406eb0 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -88,7 +88,7 @@ do_stage_append() {
}
do_stage_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR}/${HOST_SYS}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
index 00184a9dac..9e20ae63e6 100644
--- a/recipes/perl/perl.inc
+++ b/recipes/perl/perl.inc
@@ -36,8 +36,8 @@ do_install() {
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl/
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
}
PACKAGES_DYNAMIC = "perl-module-*"
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2508719736..35fcc83ccc 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,12 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl \
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration