aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/vala.bbclass13
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/vala/files/static-dbus-methods.patch26
-rw-r--r--recipes/vala/vala-bootstrap-native_0.6.0.bb11
-rw-r--r--recipes/vala/vala-native_0.7.5+fso2.bb8
-rw-r--r--recipes/vala/vala.inc16
-rw-r--r--recipes/vala/vala_0.6.0.bb3
-rw-r--r--recipes/vala/vala_0.7.5+fso2.bb6
8 files changed, 36 insertions, 51 deletions
diff --git a/classes/vala.bbclass b/classes/vala.bbclass
index bcd906aeb9..125820c00c 100644
--- a/classes/vala.bbclass
+++ b/classes/vala.bbclass
@@ -1,3 +1,14 @@
DEPENDS += "vala-native"
-FILES_${PN}-dev += "${datadir}/vala/vapi/*.vapi"
+FILES_${PN}-dev += "\
+ ${datadir}/vala/vapi/*.vapi \
+ ${datadir}/vala/vapi/*.deps \
+"
+
+# .vapi and .deps files are arch independent and need to be present in the
+# staging datadir for the native vala compiler
+do_stage_append() {
+ install -d ${STAGING_DATADIR_NATIVE}/vala/vapi
+ find . -name "*.vapi" -exec install -m 0644 {} ${STAGING_DATADIR_NATIVE}/vala/vapi/ \;
+ find . -name "*.deps" -exec install -m 0644 {} ${STAGING_DATADIR_NATIVE}/vala/vapi/ \;
+}
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 92f3c6faef..8070f4c144 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -24506,6 +24506,10 @@ sha256=d0425be8572be85b8a7ae802a19bcb73fdeac74906f7bcbbc129697ea6a86f3a
md5=9e5888a79757eb0f47df118b39762ed6
sha256=9d1cb3661e6c15059e4eecce323b3f118c243d1f17a1883e2b2d7ca0a16987e5
+[http://www.freesmartphone.org/sources/vala-0.7.5-fso2.tar.gz]
+md5=1a10e3c3d7c8eab324ecb0d8b81732bd
+sha256=4dfd1ff2793f71ab11d842ff4379a676a30af4287b7b6892ba9733bf7b691c10
+
[http://www.valgrind.org/downloads/valgrind-3.2.1.tar.bz2]
md5=9407d33961186814cef0e6ecedfd6318
sha256=7f9a15d7be16ca03a0912191e8d55a486bf69690e11bb76ccece3eaff3730a33
diff --git a/recipes/vala/files/static-dbus-methods.patch b/recipes/vala/files/static-dbus-methods.patch
deleted file mode 100644
index 7bf4144860..0000000000
--- a/recipes/vala/files/static-dbus-methods.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Frederik Sdun <frederik.sdun@googlemail.com>
-Hi,
-
-I figured out that vala generates wrong code on static methods. It tries
-to add a user_data pointer, but then the C function has no void*
-user_data.
-
-I appended a diff which fixes the problem for me.
-
-Regards, Frederik
-
-Index: vala/gobject/valadbusclientmodule.vala
-===================================================================
---- vala/gobject/valadbusclientmodule.vala (Revision 2430)
-+++ vala/gobject/valadbusclientmodule.vala (Arbeitskopie)
-@@ -133,7 +133,9 @@
- cend_call.add_argument (new CCodeIdentifier ("call"));
- cend_call.add_argument (new CCodeUnaryExpression (CCodeUnaryOperator.ADDRESS_OF, new CCodeIdentifier ("error")));
- var creply_call = new CCodeFunctionCall ((CCodeExpression) callback.ccodenode);
-- creply_call.add_argument (new CCodeIdentifier ("user_data"));
-+ if( reply_method.binding != MemberBinding.STATIC ) {
-+ creply_call.add_argument (new CCodeIdentifier ("user_data"));
-+ }
- int param_count = reply_method.get_parameters ().size;
- int i = 0;
- foreach (FormalParameter param in reply_method.get_parameters ()) {
diff --git a/recipes/vala/vala-bootstrap-native_0.6.0.bb b/recipes/vala/vala-bootstrap-native_0.6.0.bb
deleted file mode 100644
index 36db7174a6..0000000000
--- a/recipes/vala/vala-bootstrap-native_0.6.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require vala.inc
-PR = "r2"
-
-inherit native
-DEPENDS = "glib-2.0-native"
-
-# work around timestamp problem in tarball
-do_compile_prepend() {
- touch gobject/gobject.vala.stamp
-}
-
diff --git a/recipes/vala/vala-native_0.7.5+fso2.bb b/recipes/vala/vala-native_0.7.5+fso2.bb
new file mode 100644
index 0000000000..7a73cf5736
--- /dev/null
+++ b/recipes/vala/vala-native_0.7.5+fso2.bb
@@ -0,0 +1,8 @@
+require vala.inc
+inherit native
+DEPENDS = "glib-2.0-native"
+
+VALA_FSO_RELEASE = "0.7.5-fso2"
+PV = "0.7.4+${VALA_FSO_RELEASE}"
+PR = "${INC_PR}.0"
+
diff --git a/recipes/vala/vala.inc b/recipes/vala/vala.inc
index f5ea1ee520..fa1cf6aaa8 100644
--- a/recipes/vala/vala.inc
+++ b/recipes/vala/vala.inc
@@ -1,19 +1,15 @@
DESCRIPTION = "Vala is a C#-like language dedicated to ease GObject programming. \
-Vala compiles to plain C and has no runtime environment nor penality whatsoever."
+Vala compiles to plain C and has no runtime environment nor penalities whatsoever."
SECTION = "devel"
DEPENDS = "glib-2.0 dbus"
-HOMEPAGE = "http://live.gnome.org/Vala"
+HOMEPAGE = "http://vala-project.org"
LICENSE = "LGPL"
+INC_PR = "r0"
-MAJV = "${@bb.data.getVar('PV',d,1)[:3]}"
+SRC_URI = "http://www.freesmartphone.org/sources/vala-${VALA_FSO_RELEASE}.tar.gz"
+S = "${WORKDIR}/vala-${VALA_FSO_RELEASE}"
-SRC_URI = "\
- http://download.gnome.org/sources/vala/${MAJV}/vala-${PV}.tar.bz2 \
- file://static-dbus-methods.patch;patch=1 \
-"
-S = "${WORKDIR}/vala-${PV}"
-
-inherit autotools autotools_stage lib_package
+inherit autotools_stage
EXTRA_OECONF = "--enable-vapigen"
diff --git a/recipes/vala/vala_0.6.0.bb b/recipes/vala/vala_0.6.0.bb
deleted file mode 100644
index e03e39f002..0000000000
--- a/recipes/vala/vala_0.6.0.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require vala.inc
-DEPENDS = "vala-bootstrap-native"
-PR = "r2"
diff --git a/recipes/vala/vala_0.7.5+fso2.bb b/recipes/vala/vala_0.7.5+fso2.bb
new file mode 100644
index 0000000000..fff355ebaf
--- /dev/null
+++ b/recipes/vala/vala_0.7.5+fso2.bb
@@ -0,0 +1,6 @@
+require vala.inc
+VALA_FSO_RELEASE = "0.7.5-fso2"
+PV = "0.7.4+${VALA_FSO_RELEASE}"
+PR = "${INC_PR}.0"
+
+