aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/abiword/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/abiword/files')
-rw-r--r--recipes/abiword/files/abiword-cxx-for-ld-fix.patch12
-rw-r--r--recipes/abiword/files/abiword-plugin-pdf-poppler.patch11
-rwxr-xr-xrecipes/abiword/files/cdump.pl32
3 files changed, 55 insertions, 0 deletions
diff --git a/recipes/abiword/files/abiword-cxx-for-ld-fix.patch b/recipes/abiword/files/abiword-cxx-for-ld-fix.patch
new file mode 100644
index 0000000000..e49b1e92e5
--- /dev/null
+++ b/recipes/abiword/files/abiword-cxx-for-ld-fix.patch
@@ -0,0 +1,12 @@
+libstc++ isn't in staging anymore, so we must use g++ for linking
+
+--- /tmp/configure.ac 2008-03-31 11:39:13.130631737 +0200
++++ abiword-plugins-2.6.0/configure.ac 2008-03-31 11:39:22.754586487 +0200
+@@ -14,6 +14,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++AC_LANG_CPLUSPLUS
+
+ AM_INIT_AUTOMAKE
+
diff --git a/recipes/abiword/files/abiword-plugin-pdf-poppler.patch b/recipes/abiword/files/abiword-plugin-pdf-poppler.patch
new file mode 100644
index 0000000000..c8ef3256b8
--- /dev/null
+++ b/recipes/abiword/files/abiword-plugin-pdf-poppler.patch
@@ -0,0 +1,11 @@
+--- abiword-2.4.4/abiword-plugins/wp/impexp/pdf/xp/ie_imp_PDF.cpp.orig 2006-04-17 11:36:05.000000000 +0100
++++ abiword-2.4.4/abiword-plugins/wp/impexp/pdf/xp/ie_imp_PDF.cpp 2006-04-17 11:37:00.000000000 +0100
+@@ -75,7 +75,7 @@
+ UT_tmpnam(temporary_file);
+
+ TextOutputDev *textOut = new TextOutputDev(temporary_file, gFalse, gFalse, gFalse);
+- doc->displayPages(textOut, 1, doc->getNumPages(), 72, 72, 0, gTrue, gFalse);
++ doc->displayPages(textOut, 1, doc->getNumPages(), 72, 72, 0, gFalse, gTrue, gFalse);
+ delete textOut;
+
+ IE_Imp_Text txt_imp(getDoc(), "UTF-8");
diff --git a/recipes/abiword/files/cdump.pl b/recipes/abiword/files/cdump.pl
new file mode 100755
index 0000000000..76f9c8841b
--- /dev/null
+++ b/recipes/abiword/files/cdump.pl
@@ -0,0 +1,32 @@
+#!/usr/bin/perl
+
+# This script replace the cdump tool we used to build the ap_wp_Splash.cpp
+# Because the cdump tool has to be run as a part of building the AW package,
+# it breaks cross-compilation. A perl script seemed like a generic solution
+
+
+if ($#ARGV != 1 )
+{
+ print "Usage: $0 datafile arrayname $#ARGV $ARGV[0] $ARGV[1]\n";
+ exit(-1);
+}
+
+open FROM, "<$ARGV[0]" or die "Could not open file $ARGV[0]";
+binmode FROM;
+
+print "unsigned char $ARGV[1] [] = {\n";
+
+while ($len = read(FROM, $buf, 16))
+{
+ foreach(split(//,$buf))
+ {
+ printf("0x%02x,", ord($_));
+ }
+
+ print "\n";
+}
+
+
+printf "};\nunsigned long $ARGV[1]_sizeof = sizeof($ARGV[1]);\n";
+
+close FROM; \ No newline at end of file