aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/blueprobe/blueprobe-0.18
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/blueprobe/blueprobe-0.18')
-rw-r--r--recipes/blueprobe/blueprobe-0.18/fix-makefile.patch13
-rw-r--r--recipes/blueprobe/blueprobe-0.18/h4000.patch16
-rw-r--r--recipes/blueprobe/blueprobe-0.18/uclibc-fix.patch30
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes/blueprobe/blueprobe-0.18/fix-makefile.patch b/recipes/blueprobe/blueprobe-0.18/fix-makefile.patch
new file mode 100644
index 0000000000..f1bad8b707
--- /dev/null
+++ b/recipes/blueprobe/blueprobe-0.18/fix-makefile.patch
@@ -0,0 +1,13 @@
+Index: blueprobe-0.18/Makefile
+===================================================================
+--- blueprobe-0.18.orig/Makefile
++++ blueprobe-0.18/Makefile
+@@ -28,7 +28,7 @@
+ install-program: $(PACKAGE)
+ install -d $(DESTDIR)/etc/sysconfig
+ install -d $(DESTDIR)$(PREFIX)/bin
+- install -s $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
++ install $(PACKAGE) $(DESTDIR)$(PREFIX)/bin/$(PACKAGE)
+ install -d $(DESTDIR)/etc/init.d
+ install $(PACKAGE).init $(DESTDIR)/etc/init.d/$(PACKAGE)
+ install -d $(DESTDIR)/etc/rcS.d
diff --git a/recipes/blueprobe/blueprobe-0.18/h4000.patch b/recipes/blueprobe/blueprobe-0.18/h4000.patch
new file mode 100644
index 0000000000..79ea3ebae4
--- /dev/null
+++ b/recipes/blueprobe/blueprobe-0.18/h4000.patch
@@ -0,0 +1,16 @@
+--- blueprobe-0.18/blueprobe.init.org 2007-01-11 11:54:09.000000000 +0000
++++ blueprobe-0.18/blueprobe.init 2007-02-11 17:05:51.000000000 +0000
+@@ -65,6 +65,13 @@
+ PROTO=bcsp
+ PROBE=yes
+ ;;
++ "HP iPAQ H4100" | "HP iPAQ H4300")
++ BLUETOOTH=yes
++ PORT=/dev/ttyS1
++ SPEED=115200
++ PROTO=texas
++ PROBE=no
++ ;;
+ "HP iPAQ HX4700")
+ BLUETOOTH=yes
+ PORT=/dev/ttyS1
diff --git a/recipes/blueprobe/blueprobe-0.18/uclibc-fix.patch b/recipes/blueprobe/blueprobe-0.18/uclibc-fix.patch
new file mode 100644
index 0000000000..34a1711e60
--- /dev/null
+++ b/recipes/blueprobe/blueprobe-0.18/uclibc-fix.patch
@@ -0,0 +1,30 @@
+Uclibc doesn't define or support speeds above 115200. So check the existence
+of the defines before allowing them to actually be used.
+
+Index: blueprobe-0.18/blueprobe.c
+===================================================================
+--- blueprobe-0.18.orig/blueprobe.c 2006-10-12 20:33:01.000000000 +1000
++++ blueprobe-0.18/blueprobe.c 2007-05-17 12:29:20.000000000 +1000
+@@ -25,14 +25,22 @@
+ return B57600;
+ case 115200:
+ return B115200;
++#ifdef B230400
+ case 230400:
+ return B230400;
++#endif
++#ifdef B460800
+ case 460800:
+ return B460800;
++#endif
++#ifdef B921600
+ case 921600:
+ return B921600;
++#endif
++#ifdef B1000000
+ case 1000000:
+ return B1000000;
++#endif
+ default:
+ return B57600;
+ }