aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/bluez/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/bluez/files')
-rw-r--r--recipes/bluez/files/base.patch33
-rw-r--r--recipes/bluez/files/blueboxes.patch18
-rw-r--r--recipes/bluez/files/bluetooth.conf13
-rw-r--r--recipes/bluez/files/bluetooth.default37
-rw-r--r--recipes/bluez/files/default-manfid-0x0-to-bcps.patch22
-rw-r--r--recipes/bluez/files/hciattach_devlength.patch11
-rw-r--r--recipes/bluez/files/no-user-include.patch18
-rw-r--r--recipes/bluez/files/openmn/bluetooth.default37
-rw-r--r--recipes/bluez/files/openmn/hcid.conf70
-rw-r--r--recipes/bluez/files/pkgconfig-add-gthread.patch50
-rw-r--r--recipes/bluez/files/slugos/bluetooth.default37
-rw-r--r--recipes/bluez/files/slugos/hcid.conf70
12 files changed, 416 insertions, 0 deletions
diff --git a/recipes/bluez/files/base.patch b/recipes/bluez/files/base.patch
new file mode 100644
index 0000000000..337c9aa73e
--- /dev/null
+++ b/recipes/bluez/files/base.patch
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.17/pcmcia/bluetooth~base.patch
++++ bluez-utils-2.17/pcmcia/bluetooth
+@@ -15,9 +15,16 @@
+
+ if [ -r ./shared ]; then . ./shared ; else . /etc/pcmcia/shared ; fi
+
++# Give the port some time to complete initialization
++sleep 5
++
+ # Get device attributes
+ get_info $DEVICE
+
++test "$DEVICE" = "ttyS7" && DEVICE="/dev/tts/7"
++test -z "$MANFID" && MANFID="bcsp"
++test "$MANFID" = "0000,0000" && MANFID="bcsp"
++
+ #
+ # Serial devices
+ #
+@@ -25,7 +32,7 @@
+ IRQ=`setserial /dev/$DEVICE | sed -e 's/.*IRQ: //'`
+ setserial /dev/$DEVICE irq 0 ; setserial /dev/$DEVICE irq $IRQ
+
+- /usr/sbin/hciattach $DEVICE $MANFID
++ /sbin/hciattach $DEVICE $MANFID
+ }
+ stop_serial() {
+ do_fuser -k -HUP /dev/$DEVICE > /dev/null
diff --git a/recipes/bluez/files/blueboxes.patch b/recipes/bluez/files/blueboxes.patch
new file mode 100644
index 0000000000..c429b06c06
--- /dev/null
+++ b/recipes/bluez/files/blueboxes.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.14/pcmcia/bluetooth.conf~base
++++ bluez-utils-2.14/pcmcia/bluetooth.conf
+@@ -26,6 +26,10 @@
+ version "Brain Boxes", "Bluetooth PC Card"
+ bind "serial_cs" class "bluetooth"
+
++card "F+ Bluetooth_Card, BCSP"
++ manfid 0x0160, 0xaba0
++ bind "serial_cs" class "bluetooth"
++
+ card "IBM Bluetooth PC Card II"
+ version "IBM", "Bluetooth PC Card II"
+ bind "serial_cs" class "bluetooth"
diff --git a/recipes/bluez/files/bluetooth.conf b/recipes/bluez/files/bluetooth.conf
new file mode 100644
index 0000000000..872084702a
--- /dev/null
+++ b/recipes/bluez/files/bluetooth.conf
@@ -0,0 +1,13 @@
+#
+# additional cards for /etc/pcmcia/bluetooth.conf
+# Note for OE: This file is _appended_ to the stock
+# bluetooth.conf in bluez-utils, so no need to duplicate
+# entries for individual cards.
+#
+card "CSR BT01x0M Bluetooth CF Card"
+ version "Bluetooth BT0100M", "", ""
+ bind "serial_cs" class "bluetooth"
+
+card "Socket Bluetooth CF Card Rev. G"
+ manfid 0x0104, 0x0096
+ bind "serial_cs" class "bluetooth"
diff --git a/recipes/bluez/files/bluetooth.default b/recipes/bluez/files/bluetooth.default
new file mode 100644
index 0000000000..4817d38c60
--- /dev/null
+++ b/recipes/bluez/files/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=true
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=true
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=true
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=false
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=false
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/recipes/bluez/files/default-manfid-0x0-to-bcps.patch b/recipes/bluez/files/default-manfid-0x0-to-bcps.patch
new file mode 100644
index 0000000000..3d993543b3
--- /dev/null
+++ b/recipes/bluez/files/default-manfid-0x0-to-bcps.patch
@@ -0,0 +1,22 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- bluez-utils-2.16/tools/hciattach.c~default-manfid-0x0-to-bcps
++++ bluez-utils-2.16/tools/hciattach.c
+@@ -796,13 +796,12 @@
+ }
+
+ struct uart_t uart[] = {
++ { "bcsp", 0x0000, 0x0000, HCI_UART_BCSP, 115200, 115200, 0, bcsp },
+ { "any", 0x0000, 0x0000, HCI_UART_H4, 115200, 115200, FLOW_CTL, NULL },
+ { "ericsson", 0x0000, 0x0000, HCI_UART_H4, 57600, 115200, FLOW_CTL, ericsson },
+ { "digi", 0x0000, 0x0000, HCI_UART_H4, 9600, 115200, FLOW_CTL, digi },
+ { "texas", 0x0000, 0x0000, HCI_UART_H4, 115200, 115200, FLOW_CTL, texas },
+
+- { "bcsp", 0x0000, 0x0000, HCI_UART_BCSP, 115200, 115200, 0, bcsp },
+-
+ /* Xircom PCMCIA cards: Credit Card Adapter and Real Port Adapter */
+ { "xircom", 0x0105, 0x080a, HCI_UART_H4, 115200, 115200, FLOW_CTL, NULL },
+
diff --git a/recipes/bluez/files/hciattach_devlength.patch b/recipes/bluez/files/hciattach_devlength.patch
new file mode 100644
index 0000000000..8d84cb1b00
--- /dev/null
+++ b/recipes/bluez/files/hciattach_devlength.patch
@@ -0,0 +1,11 @@
+--- bluez-utils-2.21/tools/hciattach.c.orig 2005-12-15 16:29:55.000000000 +0100
++++ bluez-utils-2.21/tools/hciattach.c 2005-12-15 16:29:37.000000000 +0100
+@@ -973,7 +973,7 @@
+ int send_break = 0;
+ pid_t pid;
+ struct sigaction sa;
+- char dev[20];
++ char dev[25];
+
+ detach = 1;
+ printpid = 0;
diff --git a/recipes/bluez/files/no-user-include.patch b/recipes/bluez/files/no-user-include.patch
new file mode 100644
index 0000000000..8c1b1b6d6d
--- /dev/null
+++ b/recipes/bluez/files/no-user-include.patch
@@ -0,0 +1,18 @@
+Do not add -I/usr/include to the compile line just because we will
+install bluez-utils there says zecke...
+
+Index: bluez-utils-2.25/acinclude.m4
+===================================================================
+--- bluez-utils-2.25.orig/acinclude.m4 2006-05-18 12:39:57.473577920 +0200
++++ bluez-utils-2.25/acinclude.m4 2006-05-19 00:58:52.694599848 +0200
+@@ -69,7 +69,9 @@
+ ac_save_LDFLAGS=$LDFLAGS
+
+ BLUEZ_CFLAGS=""
+- test -d "${bluez_prefix}/include" && BLUEZ_CFLAGS="$BLUEZ_CFLAGS -I${bluez_prefix}/include"
++ if test "$cross_compiling" = no; then
++ test -d "${bluez_prefix}/include" && BLUEZ_CFLAGS="$BLUEZ_CFLAGS -I${bluez_prefix}/include"
++ fi
+
+ CPPFLAGS="$CPPFLAGS $BLUEZ_CFLAGS"
+ AC_CHECK_HEADER(bluetooth/bluetooth.h, dummy=yes, AC_MSG_ERROR(Bluetooth header files not found))
diff --git a/recipes/bluez/files/openmn/bluetooth.default b/recipes/bluez/files/openmn/bluetooth.default
new file mode 100644
index 0000000000..06c52d7960
--- /dev/null
+++ b/recipes/bluez/files/openmn/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=false
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=false
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=false
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=false
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=false
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/recipes/bluez/files/openmn/hcid.conf b/recipes/bluez/files/openmn/hcid.conf
new file mode 100644
index 0000000000..46a5d5fd54
--- /dev/null
+++ b/recipes/bluez/files/openmn/hcid.conf
@@ -0,0 +1,70 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ # pin_helper /bin/bluepin;
+
+ # D-Bus PIN helper
+ # dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x820100;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ lm accept,master;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ auth enable;
+ encrypt enable;
+}
diff --git a/recipes/bluez/files/pkgconfig-add-gthread.patch b/recipes/bluez/files/pkgconfig-add-gthread.patch
new file mode 100644
index 0000000000..2dde6b81f5
--- /dev/null
+++ b/recipes/bluez/files/pkgconfig-add-gthread.patch
@@ -0,0 +1,50 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2007-07-17 17:25:52.000000000 +0100
++++ git/configure.in 2007-07-17 17:25:52.000000000 +0100
+@@ -75,6 +75,10 @@
+ AC_SUBST(OPENOBEX_CFLAGS)
+ AC_SUBST(OPENOBEX_LIBS)
+
++PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.10, dummy=yes, dummy=no)
++AC_SUBST(GTHREAD_CFLAGS)
++AC_SUBST(GTHREAD_LIBS)
++
+ AC_ARG_BLUEZ
+
+ AC_OUTPUT(Makefile compat/Makefile common/Makefile applet/Makefile properties/Makefile sendto/Makefile wizard/Makefile proximity/Makefile po/Makefile.in)
+Index: git/applet/Makefile.am
+===================================================================
+--- git.orig/applet/Makefile.am 2007-07-17 17:25:52.000000000 +0100
++++ git/applet/Makefile.am 2007-07-17 17:25:52.000000000 +0100
+@@ -4,12 +4,12 @@
+ bluetooth_applet_SOURCES = main.c
+
+ bluetooth_applet_LDADD = $(top_builddir)/compat/libcompat.a $(top_builddir)/common/libcommon.a \
+- @NOTIFY_LIBS@ @GCONF_LIBS@ @GTK_LIBS@ @HAL_LIBS@ @DBUS_LIBS@
++ @NOTIFY_LIBS@ @GCONF_LIBS@ @GTK_LIBS@ @HAL_LIBS@ @DBUS_LIBS@ @GTHREAD_LIBS@
+
+ nodist_bluetooth_applet_SOURCES = $(top_builddir)/common/passkey-agent-glue.h \
+ $(top_builddir)/common/auth-agent-glue.h
+
+-AM_CFLAGS = @DBUS_CFLAGS@ @HAL_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@ @NOTIFY_CFLAGS@ -DSYSCONFDIR=\"$(sysconfdir)\"
++AM_CFLAGS = @DBUS_CFLAGS@ @HAL_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@ @NOTIFY_CFLAGS@ @GTHREAD_CFLAGS@ -DSYSCONFDIR=\"$(sysconfdir)\"
+
+ INCLUDES = -I$(top_builddir)/common -I$(top_srcdir)/compat
+
+Index: git/properties/Makefile.am
+===================================================================
+--- git.orig/properties/Makefile.am 2007-07-17 17:28:11.000000000 +0100
++++ git/properties/Makefile.am 2007-07-17 17:28:44.000000000 +0100
+@@ -4,9 +4,9 @@
+ bluetooth_properties_SOURCES = main.c
+
+ bluetooth_properties_LDADD = $(top_builddir)/common/libcommon.a \
+- @GCONF_LIBS@ @GTK_LIBS@ @HAL_LIBS@ @DBUS_LIBS@
++ @GCONF_LIBS@ @GTK_LIBS@ @HAL_LIBS@ @DBUS_LIBS@ @GTHREAD_LIBS@
+
+-AM_CFLAGS = @DBUS_CFLAGS@ @HAL_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@
++AM_CFLAGS = @DBUS_CFLAGS@ @HAL_CFLAGS@ @GTK_CFLAGS@ @GCONF_CFLAGS@ @GTHREAD_CFLAGS@
+
+ INCLUDES = -I$(top_srcdir)/common
+
diff --git a/recipes/bluez/files/slugos/bluetooth.default b/recipes/bluez/files/slugos/bluetooth.default
new file mode 100644
index 0000000000..10f628e314
--- /dev/null
+++ b/recipes/bluez/files/slugos/bluetooth.default
@@ -0,0 +1,37 @@
+# Bluetooth configuraton file
+
+# Start of hcid (allowed values are "true" and "false")
+HCID_ENABLE=true
+
+# Config file for hcid
+HCID_CONFIG="/etc/bluetooth/hcid.conf"
+
+# Start sdpd (allowed values are "true" and "false")
+SDPD_ENABLE=true
+
+# Start hidd (allowed values are "true" and "false")
+HIDD_ENABLE=false
+
+# Arguments to hidd
+HIDD_OPTIONS=""
+
+# Run hid2hci (allowed values are "true" and "false")
+HID2HCI_ENABLE=false
+
+# Bind rfcomm devices (allowed values are "true" and "false")
+RFCOMM_ENABLE=true
+
+# Config file for rfcomm
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+# Start dund (allowed values are "true" and "false")
+DUND_ENABLE=true
+
+# Arguments to dund
+DUND_OPTIONS="--listen --persist"
+
+# Start pand (allowed values are "true" and "false")
+PAND_ENABLE=true
+
+# Arguments to pand
+PAND_OPTIONS="--listen --role NAP"
diff --git a/recipes/bluez/files/slugos/hcid.conf b/recipes/bluez/files/slugos/hcid.conf
new file mode 100644
index 0000000000..46a5d5fd54
--- /dev/null
+++ b/recipes/bluez/files/slugos/hcid.conf
@@ -0,0 +1,70 @@
+#
+# HCI daemon configuration file.
+#
+# $Id: hcid.conf,v 1.4 2004/04/29 20:14:21 holtmann Exp $
+#
+
+# HCId options
+options {
+ # Automatically initialize new devices
+ autoinit yes;
+
+ # Security Manager mode
+ # none - Security manager disabled
+ # auto - Use local PIN for incoming connections
+ # user - Always ask user for a PIN
+ #
+ security auto;
+
+ # Pairing mode
+ # none - Pairing disabled
+ # multi - Allow pairing with already paired devices
+ # once - Pair once and deny successive attempts
+ pairing multi;
+
+ # PIN helper
+ # pin_helper /bin/bluepin;
+
+ # D-Bus PIN helper
+ # dbus_pin_helper;
+}
+
+# Default settings for HCI devices
+device {
+ # Local device name
+ # %d - device id
+ # %h - host name
+ name "%h";
+
+ # Local device class
+ class 0x820100;
+
+ # Default packet type
+ #pkt_type DH1,DM1,HV1;
+
+ # Inquiry and Page scan
+ iscan enable; pscan enable;
+
+ # Default link mode
+ # none - no specific policy
+ # accept - always accept incoming connections
+ # master - become master on incoming connections,
+ # deny role switch on outgoing connections
+ #
+ lm accept,master;
+
+ # Default link policy
+ # none - no specific policy
+ # rswitch - allow role switch
+ # hold - allow hold mode
+ # sniff - allow sniff mode
+ # park - allow park mode
+ #
+ #lp hold,sniff;
+ #
+ lp rswitch,hold,sniff,park;
+
+ # Authentication and Encryption
+ auth enable;
+ encrypt enable;
+}