aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/cherokee/cherokee-0.5.3
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/cherokee/cherokee-0.5.3')
-rw-r--r--recipes/cherokee/cherokee-0.5.3/Makefile.cget.patch23
-rw-r--r--recipes/cherokee/cherokee-0.5.3/Makefile.in.patch32
-rw-r--r--recipes/cherokee/cherokee-0.5.3/configure.patch127
-rw-r--r--recipes/cherokee/cherokee-0.5.3/util.patch29
4 files changed, 211 insertions, 0 deletions
diff --git a/recipes/cherokee/cherokee-0.5.3/Makefile.cget.patch b/recipes/cherokee/cherokee-0.5.3/Makefile.cget.patch
new file mode 100644
index 0000000000..bb6b2141b3
--- /dev/null
+++ b/recipes/cherokee/cherokee-0.5.3/Makefile.cget.patch
@@ -0,0 +1,23 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/cget/Makefile.in~Makefile.cget
++++ cherokee-0.4.29/cget/Makefile.in
+@@ -56,6 +56,7 @@
+ cget_OBJECTS = $(am_cget_OBJECTS)
+ am__DEPENDENCIES_1 =
+ cget_DEPENDENCIES = ../cherokee/libcherokee-client.la \
++ ../cherokee/libcherokee-base.la \
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(am__DEPENDENCIES_1)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+@@ -286,6 +287,7 @@
+
+ cget_LDADD = \
+ ../cherokee/libcherokee-client.la \
++../cherokee/libcherokee-base.la \
+ $(TLS_LIBS) \
+ $(PTHREAD_LIBS) \
+ $(PTHREAD_CFLAGS)
diff --git a/recipes/cherokee/cherokee-0.5.3/Makefile.in.patch b/recipes/cherokee/cherokee-0.5.3/Makefile.in.patch
new file mode 100644
index 0000000000..05ece037c3
--- /dev/null
+++ b/recipes/cherokee/cherokee-0.5.3/Makefile.in.patch
@@ -0,0 +1,32 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+Index: cherokee-0.5.3/cherokee/Makefile.in
+===================================================================
+--- cherokee-0.5.3.orig/cherokee/Makefile.in 2006-04-22 20:03:20.000000000 +0200
++++ cherokee-0.5.3/cherokee/Makefile.in 2006-05-23 20:33:12.000000000 +0200
+@@ -434,11 +434,11 @@
+ am_cherokee_OBJECTS = main.$(OBJEXT)
+ cherokee_OBJECTS = $(am_cherokee_OBJECTS)
+ cherokee_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+- libcherokee-base.la libcherokee-server.la
++ libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ am_cherokee_admin_OBJECTS = cherokee_admin.$(OBJEXT)
+ cherokee_admin_OBJECTS = $(am_cherokee_admin_OBJECTS)
+ cherokee_admin_DEPENDENCIES = libcherokee-config.la \
+- libcherokee-base.la libcherokee-client.la
++ libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ am_cherokee_logrotate_OBJECTS = cherokee_logrotate.$(OBJEXT)
+ cherokee_logrotate_OBJECTS = $(am_cherokee_logrotate_OBJECTS)
+ cherokee_logrotate_DEPENDENCIES = libcherokee-base.la \
+@@ -1429,7 +1429,7 @@
+ cherokee_logrotate_SOURCES = cherokee_logrotate.c
+ cherokee_logrotate_LDADD = libcherokee-base.la libcherokee-client.la libcherokee-server.la libcherokee-config.la
+ cherokee_admin_SOURCES = cherokee_admin.c
+-cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la
++cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la libcherokee-server.la
+
+ #noinst_PROGRAMS = cherokee_modules cherokee_base64 cherokee_headers cherokee_fastcgi
+
diff --git a/recipes/cherokee/cherokee-0.5.3/configure.patch b/recipes/cherokee/cherokee-0.5.3/configure.patch
new file mode 100644
index 0000000000..9c34d961ac
--- /dev/null
+++ b/recipes/cherokee/cherokee-0.5.3/configure.patch
@@ -0,0 +1,127 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/configure~configure
++++ cherokee-0.4.29/configure
+@@ -28929,59 +28929,8 @@
+ if test "x$have_epoll_include" = "xyes"; then
+ echo "$as_me:$LINENO: checking for epoll system call" >&5
+ echo $ECHO_N "checking for epoll system call... $ECHO_C" >&6
+-
+- if test "$cross_compiling" = yes; then
+- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
+-else
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
+- #include <stdint.h>
+- #include <sys/param.h>
+- #include <sys/types.h>
+- #include <sys/syscall.h>
+- #include <sys/epoll.h>
+- #include <unistd.h>
+-
+- int epoll_create (int size) {
+- return (syscall(__NR_epoll_create, size));
+- }
+-
+- int main (int argc, char **argv) {
+- int epfd;
+- epfd = epoll_create(256);
+- exit (epfd == -1 ? 1 : 0);
+- }
+-
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- have_epoll=yes
+-else
+- echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
++have_epoll=yes
++
+ echo "$as_me:$LINENO: result: $have_epoll" >&5
+ echo "${ECHO_T}$have_epoll" >&6
+ fi
+@@ -32593,55 +32542,9 @@
+ # Is sendfile broken?
+ echo "$as_me:$LINENO: checking if sendfile works" >&5
+ echo $ECHO_N "checking if sendfile works... $ECHO_C" >&6
+-if test "$cross_compiling" = yes; then
+- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
+-else
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-#include <errno.h>
+- int main() {
+- int o = 0;
+- if (-1 == sendfile(0, 0, &o, 0) && errno == ENOSYS) return -1;
+- return 0;
+- }
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-else
+- echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+
+-( exit $ac_status )
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define HAVE_SENDFILE_BROKEN 1
+-_ACEOF
+-
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
++echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
+
+ # readdir_r()
+
diff --git a/recipes/cherokee/cherokee-0.5.3/util.patch b/recipes/cherokee/cherokee-0.5.3/util.patch
new file mode 100644
index 0000000000..c7b1d15113
--- /dev/null
+++ b/recipes/cherokee/cherokee-0.5.3/util.patch
@@ -0,0 +1,29 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+Index: cherokee-0.5.3/cherokee/util.c
+===================================================================
+--- cherokee-0.5.3.orig/cherokee/util.c 2006-04-01 17:58:59.000000000 +0200
++++ cherokee-0.5.3/cherokee/util.c 2006-05-23 20:37:12.000000000 +0200
+@@ -32,6 +32,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
++#include <errno.h>
+
+ #ifdef HAVE_SYS_TIME_H
+ # include <sys/time.h>
+@@ -385,9 +386,9 @@
+
+
+
+-#if defined(HAVE_PTHREAD) && !defined(HAVE_READDIR_R)
++/*#if defined(HAVE_PTHREAD) && !defined(HAVE_READDIR_R)*/
+ static pthread_mutex_t readdir_mutex = PTHREAD_MUTEX_INITIALIZER;
+-#endif
++/*#endif*/
+
+ /* The readdir subroutine is reentrant when an application program
+ * uses different DirectoryPointer parameter values (returned from the