aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/dvsdk/files/dvsdk-rules/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/dvsdk/files/dvsdk-rules/Makefile')
-rw-r--r--recipes/dvsdk/files/dvsdk-rules/Makefile119
1 files changed, 32 insertions, 87 deletions
diff --git a/recipes/dvsdk/files/dvsdk-rules/Makefile b/recipes/dvsdk/files/dvsdk-rules/Makefile
index edb74e0999..bc1eabf249 100644
--- a/recipes/dvsdk/files/dvsdk-rules/Makefile
+++ b/recipes/dvsdk/files/dvsdk-rules/Makefile
@@ -6,20 +6,20 @@ REPOSITORIES:=$(addsuffix /packages, $(COMPONENTS))
CHECKLIST:=$(REPOSITORIES) $(CODEGEN_INSTALL_DIR)/bin/cl6x $(MVTOOL_PREFIX)gcc $(LINUXKERNEL_INSTALL_DIR)/Documentation $(DEMO_INSTALL_DIR)/$(PLATFORM) $(PSP_INSTALL_DIR)/docs
-.PHONY: all clean everything clobber help cmem cmem_clean dmai dmai_clean demos demos_clean examples examples_clean dvtb dvtb_clean dm355mm dm355mm_clean dsplink dsplink_arm dsplink_dsp dsplink_samples dsplink_clean codecs codecs_clean linux linux_clean psp_examples psp_clean info check install
+.PHONY: all clean everything clobber help cmem cmem_clean dmai dmai_clean dm355mm dm355mm_clean dsplink dsplink_arm dsplink_dsp dsplink_samples dsplink_clean codecs codecs_clean linux linux_clean info check install
#==============================================================================
# Set up platform dependent variables.
#==============================================================================
ifeq ($(PLATFORM),dm6446)
-LINUXKERNEL_CONFIG=davinci_dm644x_defconfig
+LINUXKERNEL_CONFIG=davinci_all_defconfig
LINUXSAMPLES_PLATFORM=dm644x
DSPLINK_CONFIG=--platform=DAVINCI --nodsp=1 --dspcfg_0=DM6446GEMSHMEM --dspos_0=DSPBIOS5XX --gppos=MVL5G --comps=ponslrm
DSPLINK_MODULE=$(LINK_INSTALL_DIR)/packages/dsplink/gpp/export/BIN/Linux/DAVINCI/RELEASE/dsplinkk.ko
DMAI_PLATFORM=dm6446_al
else
ifeq ($(PLATFORM),dm6467)
-LINUXKERNEL_CONFIG=davinci_dm6467_defconfig
+LINUXKERNEL_CONFIG=davinci_all_defconfig
LINUXSAMPLES_PLATFORM=dm646x
DSPLINK_CONFIG=--platform=DAVINCIHD --nodsp=1 --dspcfg_0=DM6467GEMSHMEM --dspos_0=DSPBIOS5XX --gppos=MVL5G --comps=ponslrm
DSPLINK_MODULE=$(LINK_INSTALL_DIR)/packages/dsplink/gpp/export/BIN/Linux/DAVINCIHD/RELEASE/dsplinkk.ko
@@ -38,22 +38,22 @@ endif
#==============================================================================
# The default build target.
#==============================================================================
-all: check cmem dm355mm dmai demos examples dvtb
+all: check cmem dm355mm dmai
#==============================================================================
# Clean up the targets built by 'make all'.
#==============================================================================
-clean: cmem_clean dm355mm_clean dmai_clean demos_clean examples_clean dvtb_clean
+clean: cmem_clean dm355mm_clean dmai_clean
#==============================================================================
# Build everything rebuildable.
#==============================================================================
-everything: check codecs linux dsplink psp_examples all
+everything: check codecs linux dsplink all
#==============================================================================
# Clean up all targets.
#==============================================================================
-clobber: clean dsplink_clean linux_clean codecs_clean psp_clean
+clobber: clean dsplink_clean linux_clean codecs_clean
#==============================================================================
# A help message target.
@@ -63,48 +63,36 @@ help:
@echo "Available build targets are:"
@echo
@echo " check : Make sure Rules.make is set up properly"
- @echo " info : List versions of DVSDK components"
+ @echo " info : List versions of DVSDK components"
@echo
@echo " all : Build the components below"
@echo " clean : Remove files generated by the 'all' target"
@echo
- @echo " cmem : Build the CMEM kernel module for $(PLATFORM)"
- @echo " cmem_clean : Remove generated cmem files."
+ @echo " cmem : Build the CMEM kernel module for $(PLATFORM)"
+ @echo " cmem_clean : Remove generated cmem files."
@echo
- @echo " dmai : Build DMAI for $(PLATFORM)_al"
- @echo " dmai_clean : Remove generated DMAI files."
- @echo
- @echo " demos : Build the DVSDK demos for $(PLATFORM)"
- @echo " demos_clean : Remove generated DVSDK demo files."
- @echo
- @echo " examples : Build examples for $(PLATFORM)"
- @echo " examples_clean : Build examples for $(PLATFORM)"
- @echo
- @echo " dvtb : Build DVTB for $(PLATFORM)"
- @echo " dvtb_clean : Remove generated DVTB files"
+ @echo " dmai : Build DMAI for $(PLATFORM)_al"
+ @echo " dmai_clean : Remove generated DMAI files."
@echo
@echo " dm355mm : Build the dm355mm kernel module"
- @echo " dm355mm_clean : Remove generated dm355mm files"
+ @echo " dm355mm_clean : Remove generated dm355mm files"
@echo
@echo "The following targets have to be explicitly built and cleaned:"
@echo
- @echo " everything : Rebuild everything including below targets"
+ @echo " everything : Rebuild everything including below targets"
@echo " clobber : Remove all generated files"
@echo
@echo " dsplink : Configure and build DSP Link for $(PLATFORM) ARM and DSP"
- @echo " dsplink_arm : Configure and build DSP Link for $(PLATFORM) ARM"
- @echo " dsplink_dsp : Configure and build DSP Link for $(PLATFORM) DSP"
- @echo " dsplink_samples : Build DSP Link ARM and DSP sample applications for $(PLATFORM)"
- @echo " dsplink_clean : Remove generated DSP Link files"
+ @echo " dsplink_arm : Configure and build DSP Link for $(PLATFORM) ARM"
+ @echo " dsplink_dsp : Configure and build DSP Link for $(PLATFORM) DSP"
+ @echo " dsplink_samples : Build DSP Link ARM and DSP sample applications "
+ @echo " dsplink_clean : Remove generated DSP Link files"
@echo
@echo " codecs : Build codec servers for $(PLATFORM)"
- @echo " codecs_clean : Remove generated codec server files"
+ @echo " codecs_clean : Remove generated codec server files"
@echo
@echo " linux : Build Linux kernel uImage for $(PLATFORM)"
- @echo " linux_clean : Remove generated Linux kernel files"
- @echo
- @echo " psp_examples : Build Linux examples for $(PLATFORM)"
- @echo " psp_clean : Build Linux examples for $(PLATFORM)"
+ @echo " linux_clean : Remove generated Linux kernel files"
@echo
@echo " install : Install binaries to $(EXEC_DIR)"
@echo
@@ -122,28 +110,6 @@ check:
@CHECKLIST="$(CHECKLIST)" $(DVSDK_INSTALL_DIR)/bin/check.sh
#==============================================================================
-# Build the dvsdk demos for the configured platform. Also, an explicit cleanup
-# target is defined.
-#==============================================================================
-demos:
- $(MAKE) -C $(DEMO_INSTALL_DIR)/$(PLATFORM)
-
-demos_clean:
- $(MAKE) -C $(DEMO_INSTALL_DIR)/$(PLATFORM) clean
-
-#==============================================================================
-# Build the Digital Video Test Bench for the configured platform. Also, an
-# explicit cleanup target is defined.
-#==============================================================================
-dvtb:
- $(MAKE) -C $(DVTB_INSTALL_DIR) $(PLATFORM)
- @echo
- @echo "dvtb can be found under $(DVTB_INSTALL_DIR)/packages/ti/sdo/dvtb/$(PLATFORM)/bin"
-
-dvtb_clean:
- $(MAKE) -C $(DVTB_INSTALL_DIR) clean
-
-#==============================================================================
# Build the Linux kernel. Also, an explicit cleanup target is defined.
#==============================================================================
linux:
@@ -156,17 +122,6 @@ linux_clean:
$(MAKE) -C $(LINUXKERNEL_INSTALL_DIR) CROSS_COMPILE=$(MVTOOL_PREFIX) clean
#==============================================================================
-# Build the PSP Linux examples. Also, an explicit cleanup target is defined.
-#==============================================================================
-psp_examples:
- $(MAKE) -C $(PSP_INSTALL_DIR)/examples PLATFORM=$(LINUXSAMPLES_PLATFORM) LINUXKERNEL_INSTALL_DIR=$(LINUXKERNEL_INSTALL_DIR) CROSS_COMPILE=$(MVTOOL_PREFIX)
- @echo
- @echo "PSP examples can be found under $(PSP_INSTALL_DIR)/examples/$(LINUXSAMPLES_PLATFORM)"
-
-psp_clean:
- $(MAKE) -C $(PSP_INSTALL_DIR)/examples PLATFORM=$(LINUXSAMPLES_PLATFORM) LINUXKERNEL_INSTALL_DIR=$(LINUXKERNEL_INSTALL_DIR) clean
-
-#==============================================================================
# Build the CMEM kernel module for the configured platform, and make sure the
# kernel_binaries directory is kept in sync. Also, an explicit cleanup target
# is defined.
@@ -216,34 +171,24 @@ ifeq ($(PLATFORM),dm355)
endif
#==============================================================================
-# Build the DVSDK examples for the configured platform. Also, an explicit
-# cleanup target is defined.
-#==============================================================================
-examples:
- $(MAKE) -C examples/$(PLATFORM)
-
-examples_clean:
- $(MAKE) -C examples/$(PLATFORM) clean
-
-#==============================================================================
# Build the Davinci Multimedia Application Interface for the configured
# platform. Also, an explicit cleanup target is defined.
#==============================================================================
dmai:
@$(MAKE) -C $(DMAI_INSTALL_DIR) PLATFORM=${DMAI_PLATFORM} \
CE_INSTALL_DIR_${DMAI_PLATFORM}=$(CE_INSTALL_DIR) \
- CODEC_INSTALL_DIR_${DMAI_PLATFORM}=$(CODEC_INSTALL_DIR) \
- LINK_INSTALL_DIR_${DMAI_PLATFORM}=$(LINK_INSTALL_DIR) \
- CMEM_INSTALL_DIR_${DMAI_PLATFORM}=$(CMEM_INSTALL_DIR) \
- FC_INSTALL_DIR_${DMAI_PLATFORM}=$(FC_INSTALL_DIR) \
- LPM_INSTALL_DIR_${DMAI_PLATFORM}=$(LPM_INSTALL_DIR) \
- XDAIS_INSTALL_DIR_${DMAI_PLATFORM}=$(XDAIS_INSTALL_DIR) \
- BIOS_INSTALL_DIR_${DMAI_PLATFORM}=$(BIOS_INSTALL_DIR) \
- LINUXLIBS_INSTALL_DIR_${DMAI_PLATFORM}=$(LINUXLIBS_INSTALL_DIR)\
- LINUXKERNEL_INSTALL_DIR_${DMAI_PLATFORM}=$(LINUXKERNEL_INSTALL_DIR) \
- CROSS_COMPILE_${DMAI_PLATFORM}=$(CSTOOL_PREFIX) \
- XDC_INSTALL_DIR_${DMAI_PLATFORM}=$(XDC_INSTALL_DIR) \
- EXEC_DIR_${DMAI_PLATFORM}=$(EXEC_DIR) all
+ CODEC_INSTALL_DIR_${DMAI_PLATFORM}=$(CODEC_INSTALL_DIR) \
+ LINK_INSTALL_DIR_${DMAI_PLATFORM}=$(LINK_INSTALL_DIR) \
+ CMEM_INSTALL_DIR_${DMAI_PLATFORM}=$(CMEM_INSTALL_DIR) \
+ FC_INSTALL_DIR_${DMAI_PLATFORM}=$(FC_INSTALL_DIR) \
+ LPM_INSTALL_DIR_${DMAI_PLATFORM}=$(LPM_INSTALL_DIR) \
+ XDAIS_INSTALL_DIR_${DMAI_PLATFORM}=$(XDAIS_INSTALL_DIR) \
+ BIOS_INSTALL_DIR_${DMAI_PLATFORM}=$(BIOS_INSTALL_DIR) \
+ LINUXLIBS_INSTALL_DIR_${DMAI_PLATFORM}=$(LINUXLIBS_INSTALL_DIR)\
+ LINUXKERNEL_INSTALL_DIR_${DMAI_PLATFORM}=$(LINUXKERNEL_INSTALL_DIR) \
+ CROSS_COMPILE_${DMAI_PLATFORM}=$(CSTOOL_PREFIX) \
+ XDC_INSTALL_DIR_${DMAI_PLATFORM}=$(XDC_INSTALL_DIR) \
+ EXEC_DIR_${DMAI_PLATFORM}=$(EXEC_DIR) all
@echo
@echo "DMAI applications can be found under $(DMAI_INSTALL_DIR)/packages/ti/sdo/dmai/apps"