aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/gs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/gs')
-rw-r--r--recipes/gs/gs_8.16.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gs/gs_8.16.bb b/recipes/gs/gs_8.16.bb
new file mode 100644
index 0000000000..cf1e8ba411
--- /dev/null
+++ b/recipes/gs/gs_8.16.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "An interpreter of the Postscript language"
+LICENSE = "GPL"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
+DEPENDS = "jpeg zlib"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/ghostscript/gnu-ghostscript-${PV}.tar.gz"
+S = "${WORKDIR}/gnu-ghostscript-${PV}"
+
+inherit autotools flow-lossage
+
+EXTRA_OECONF = "--without-x"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install() {
+ oe_runmake bindir='${D}${bindir}' datadir='${D}${datadir}' libdir='${D}${libdir}' install
+}
+
+FILES_${PN} += "${datadir}/ghostscript"