aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/console-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/console-image.bb')
-rw-r--r--recipes/images/console-image.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/images/console-image.bb b/recipes/images/console-image.bb
new file mode 100644
index 0000000000..76cb8f034e
--- /dev/null
+++ b/recipes/images/console-image.bb
@@ -0,0 +1,20 @@
+#Angstrom bootstrap image
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+DEPENDS = "task-base-extended \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+IMAGE_INSTALL = "task-base-extended \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)} \
+ "
+
+export IMAGE_BASENAME = "console-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+