aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/initramfs-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/initramfs-image.bb')
-rw-r--r--recipes/images/initramfs-image.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/images/initramfs-image.bb b/recipes/images/initramfs-image.bb
new file mode 100644
index 0000000000..d3d1d751cf
--- /dev/null
+++ b/recipes/images/initramfs-image.bb
@@ -0,0 +1,13 @@
+# initramfs image allowing to boot from location as specified on kernel
+# command line, from teh choices of block device, loop back images (including
+# recursive) and NFS.
+
+IMAGE_INSTALL = "initramfs-module-block initramfs-module-loop initramfs-module-nfs"
+IMAGE_LINGUAS = ""
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules"
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+inherit image