aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/udumpty-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/udumpty-image.bb')
-rw-r--r--recipes/images/udumpty-image.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/images/udumpty-image.bb b/recipes/images/udumpty-image.bb
new file mode 100644
index 0000000000..c55381ed30
--- /dev/null
+++ b/recipes/images/udumpty-image.bb
@@ -0,0 +1,53 @@
+# Image that mimics the default desktop of a certain distro
+
+XSERVER ?= "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-video-fbdev \
+ xf86-input-keyboard \
+"
+
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+export IMAGE_BASENAME = "Udumpty-image"
+
+DEPENDS = "task-base"
+IMAGE_INSTALL = "\
+ ${XSERVER} \
+ task-base-extended \
+ angstrom-x11-base-depends \
+ angstrom-gpe-task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ angstrom-zeroconf-audio \
+ angstrom-led-config \
+ gpe-scap \
+ psplash \
+ metacity \
+ xterm \
+ epiphany \
+ swfdec-mozilla \
+ hicolor-icon-theme gnome-icon-theme \
+ abiword \
+ gnumeric \
+ gimp \
+ powertop oprofile \
+ pidgin \
+ totem mplayer omapfbplay \
+ gnome-games \
+ rt73-firmware zd1211-firmware \
+ synergy \
+ x11vnc \
+ angstrom-gnome-icon-theme-enable \
+ gnome-panel \
+ gnome-control-center \
+ gnome-settings-daemon \
+ gnome-session \
+"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+#zap root password for release images
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+
+inherit image