aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/qt4e-base-image.bb51
-rw-r--r--recipes/images/qt4e-demo-image.bb7
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes/images/qt4e-base-image.bb b/recipes/images/qt4e-base-image.bb
new file mode 100644
index 0000000000..4aa24dac51
--- /dev/null
+++ b/recipes/images/qt4e-base-image.bb
@@ -0,0 +1,51 @@
+require micro-base-image.bb
+
+TOUCH = ' ${@base_contains("MACHINE_FEATURES", "touchscreen", "tslib tslib-calibrate tslib-tests", "",d)}'
+
+RDEPENDS_append += " \
+ qt4-embedded \
+ "
+
+QTE_INSTALL = " \
+ libqt-embedded3support4 \
+ libqt-embeddedclucene4 \
+ libqt-embeddedcore4 \
+ libqt-embeddeddbus4 \
+ libqt-embeddedgui4 \
+ libqt-embeddedhelp4 \
+ libqt-embeddedmultimedia4 \
+ libqt-embeddednetwork4 \
+ libqt-embeddedscript4 \
+ libqt-embeddedscripttools4 \
+ libqt-embeddedsql4 \
+ libqt-embeddedsvg4 \
+ libqt-embeddedtest4 \
+ libqt-embeddedwebkit4 \
+ libqt-embeddedxml4 \
+ libqt-embeddedxmlpatterns4 \
+ qt4-embedded-fonts-ttf-dejavu \
+ qt4-embedded-fonts-ttf-vera \
+ qt4-embedded-plugin-iconengine-svgicon \
+ qt4-embedded-plugin-imageformat-gif \
+ qt4-embedded-plugin-imageformat-ico \
+ qt4-embedded-plugin-imageformat-jpeg \
+ qt4-embedded-plugin-imageformat-mng \
+ qt4-embedded-plugin-imageformat-svg \
+ qt4-embedded-plugin-imageformat-tiff \
+ qt4-embedded-plugin-mousedriver-tslib \
+ qt4-embedded-plugin-phonon-backend-gstreamer \
+ qt4-embedded-plugin-script-dbus \
+ qt4-embedded-plugin-sqldriver-sqlite2 \
+ qt4-embedded-plugin-sqldriver-sqlite \
+"
+
+IMAGE_INSTALL += "\
+ initscripts \
+ kernel-modules \
+ gdbserver \
+ strace \
+ module-init-tools \
+ ${QTE_INSTALL} \
+ ${TOUCH} \
+ qwt-e \
+"
diff --git a/recipes/images/qt4e-demo-image.bb b/recipes/images/qt4e-demo-image.bb
new file mode 100644
index 0000000000..b442a2e357
--- /dev/null
+++ b/recipes/images/qt4e-demo-image.bb
@@ -0,0 +1,7 @@
+require qt4e-base-image.bb
+
+IMAGE_INSTALL += "\
+ qt4-embedded-demos qt4-embedded-examples qt-demo-init \
+ qt4-embedded-assistant \
+ qwt-e-examples \
+"