aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libarena
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libarena')
-rw-r--r--recipes/libarena/libarena_0.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/libarena/libarena_0.2.bb b/recipes/libarena/libarena_0.2.bb
new file mode 100644
index 0000000000..9cd0e21c73
--- /dev/null
+++ b/recipes/libarena/libarena_0.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "libarena is a custom memory allocator interface and implementation. \
+Three allocators are provided: flat "LIFO" arena allocator, object pool allocator and a malloc(3) wrapper."
+HOMEPAGE = "http://www.25thandclement.com/~william/projects/libarena.html"
+SECTION = "libs"
+LICENSE = "${PN}"
+
+SRC_URI = "http://www.25thandclement.com/~william/projects/releases/libarena-${PV}.tgz"
+
+do_stage() {
+ oe_libinstall -C src -a libarena ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/arena
+ install src/*.h ${STAGING_INCDIR}/arena
+}
+