aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsigc++-2.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsigc++-2.0')
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb7
-rw-r--r--recipes/libsigc++-2.0/libsigc++-2.0_2.2.5.bb19
2 files changed, 20 insertions, 6 deletions
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
index 61d34840c9..1d2dc6372b 100644
--- a/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.2.bb
@@ -7,15 +7,10 @@ SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-${PV}.t
S = "${WORKDIR}/libsigc++-${PV}"
-inherit autotools
+inherit autotools pkgconfig
EXTRA_AUTORECONF = "--exclude=autoheader"
FILES_${PN}-dev += "${libdir}/sigc++-*/"
-AUTOTOOLS_STAGE_PKGCONFIG = "1"
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/recipes/libsigc++-2.0/libsigc++-2.0_2.2.5.bb b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.5.bb
new file mode 100644
index 0000000000..c4462309de
--- /dev/null
+++ b/recipes/libsigc++-2.0/libsigc++-2.0_2.2.5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A library for loose coupling of C++ method calls"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL"
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/libsigc++-${PV}.tar.gz;name=archive \
+ "
+
+SRC_URI[archive.md5sum] = "755f31aa887d7ef63bc62366f6ecfc42"
+SRC_URI[archive.sha256sum] = "acc121b763373e790e474e946322a6cbe501314997ebb9212b283c8623b0b52e"
+
+S = "${WORKDIR}/libsigc++-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_AUTORECONF = "--exclude=autoheader"
+
+FILES_${PN}-dev += "${libdir}/sigc++-*/"
+FILES_${PN}-doc += "${datadir}/devhelp"
+