aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/makeself
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/makeself')
-rw-r--r--recipes/makeself/makeself-native_cvs.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/makeself/makeself-native_cvs.bb b/recipes/makeself/makeself-native_cvs.bb
new file mode 100644
index 0000000000..47f6ef2f15
--- /dev/null
+++ b/recipes/makeself/makeself-native_cvs.bb
@@ -0,0 +1,16 @@
+SECTION = "devel"
+DESCRIPTION = "makeself.sh is a small shell script that generates a \
+self-extractable tar.gz archive from a directory. The resulting file \
+appears as a shell script (many of those have a .run suffix), and \
+can be launched as is. The archive will then uncompress itself to a \
+temporary directory and an optional arbitrary command will be executed \
+(for example an installation script)."
+LICENSE = "GPL"
+SRC_URI = "cvs://anonymous:anonymous@cvs.icculus.org/cvs/cvsroot;module=loki_setup/makeself"
+S = "${WORKDIR}/makeself"
+
+inherit native
+
+do_stage() {
+ install -m 0755 makeself.sh makeself-header.sh ${STAGING_BINDIR}/
+}