aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf/libnsgif_0.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/netsurf/libnsgif_0.0.2.bb')
-rw-r--r--recipes/netsurf/libnsgif_0.0.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/netsurf/libnsgif_0.0.2.bb b/recipes/netsurf/libnsgif_0.0.2.bb
new file mode 100644
index 0000000000..f9184b64ac
--- /dev/null
+++ b/recipes/netsurf/libnsgif_0.0.2.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz"
+PR = "r0"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}
+
+SRC_URI[md5sum] = "08dd5fc3ea330784f6c1e55c58244749"
+SRC_URI[sha256sum] = "dcb68be6a49ecc376cfa283d2f1e7eae035c75f99c0934ac80951e1777059617"