aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index a0fb21a3d9..69078e8b24 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -52,6 +52,17 @@ export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl/${PV}/"
# LDFLAGS for shared libraries
export LDDLFLAGS = "${LDFLAGS} -shared"
+do_nolargefile() {
+ sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
+ -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
+ -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
+ -e "/ccflags_uselargefiles/d" \
+ -e "s/-Duselargefiles//" \
+ -e "s/-D_FILE_OFFSET_BITS=64//" \
+ -e "s/-D_LARGEFILE_SOURCE//" \
+ ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
+}
+
do_configure() {
# Make hostperl in build directory be the native perl
ln -sf ${HOSTPERL} hostperl
@@ -83,6 +94,8 @@ do_configure() {
config.sh-${TARGET_ARCH}-${TARGET_OS}
fi
+ ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
+
# Update some paths in the configuration
sed -i -e 's,@DESTDIR@,${D},g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \