aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/files/0001-Find-pthread-libraries.patch31
-rw-r--r--recipes/perl/libxml-parser-perl-native_2.36.bb32
-rw-r--r--recipes/perl/perl-native_5.10.1.bb4
-rw-r--r--recipes/perl/perl_5.10.1.bb4
4 files changed, 69 insertions, 2 deletions
diff --git a/recipes/perl/files/0001-Find-pthread-libraries.patch b/recipes/perl/files/0001-Find-pthread-libraries.patch
new file mode 100644
index 0000000000..f651dbd3d3
--- /dev/null
+++ b/recipes/perl/files/0001-Find-pthread-libraries.patch
@@ -0,0 +1,31 @@
+From 69f418972f17b7f03cdc335ad14af486d06d94b2 Mon Sep 17 00:00:00 2001
+From: Ulf Samuelsson <ulf@emagii.com>
+Date: Tue, 31 Jan 2012 09:59:31 +0100
+Subject: [PATCH] Find pthread libraries
+
+Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
+---
+ hints/linux.sh | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+diff --git a/hints/linux.sh b/hints/linux.sh
+index d208129..04a99da 100644
+--- a/hints/linux.sh
++++ b/hints/linux.sh
+@@ -441,3 +441,13 @@ case "$libdb_needs_pthread" in
+ libswanted="$libswanted pthread"
+ ;;
+ esac
++
++# plibpth to bypass this check.
++case "$plibpth" in
++ '') plibpth=`gcc -print-search-dirs | grep libraries | cut -f2- -d= | tr ':' $trnl | grep -v 'gcc' | sed -e 's:/$::'`
++ set X $plibpth # Collapse all entries on one line
++ shift
++ plibpth="$*"
++ ;;
++esac
++
+--
+1.7.4.1
+
diff --git a/recipes/perl/libxml-parser-perl-native_2.36.bb b/recipes/perl/libxml-parser-perl-native_2.36.bb
new file mode 100644
index 0000000000..e46cc59395
--- /dev/null
+++ b/recipes/perl/libxml-parser-perl-native_2.36.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "XML::Parser - A perl module for parsing XML documents"
+SECTION = "libs"
+LICENSE = "Artistic|GPLv1+"
+DEPENDS += "expat expat-native"
+PR= "r4"
+
+SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
+
+S = "${WORKDIR}/XML-Parser-${PV}"
+
+EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
+
+inherit cpan
+inherit native
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/lib -name 'libc-*.so')"
+ cpan_do_compile
+}
+# cpan_do_compile || echo expected failure
+
+do_compile_virtclass-native (){
+ cpan_do_compile
+}
+
+FILES_${PN} = "${PERLLIBDIRS}/auto/XML/Parser/Expat/* \
+ ${PERLLIBDIRS}/XML"
+
+BBCLASSEXTEND="native"
+
+SRC_URI[md5sum] = "1b868962b658bd87e1563ecd56498ded"
+SRC_URI[sha256sum] = "9fd529867402456bd826fe0e5588d35b3a2e27e586a2fd838d1352b71c2ed73f"
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 3dafc10a17..f37c6cbef8 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Perl is a popular scripting language."
HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPLv1+"
-PR = "r10"
+PR = "r13"
NATIVE_INSTALL_WORKS = "1"
INHIBIT_DEFAULT_DEPS = "1"
PATCHTOOL = "patch"
@@ -21,6 +21,7 @@ SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://native-perlinc.patch \
file://perl-fix-cross-library-check.patch \
file://ubuntu-11.04-multiarch.patch \
+ file://0001-Find-pthread-libraries.patch \
"
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
@@ -108,6 +109,7 @@ do_install() {
done
create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
+ create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
}
do_install_append_nylon() {
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index 6c0dcb16da..68eaaf1b62 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -75,7 +75,9 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
file://config.sh-32-be \
file://config.sh-64 \
file://config.sh-64-le \
- file://config.sh-64-be"
+ file://config.sh-64-be \
+ file://0001-Find-pthread-libraries.patch \
+ "
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
SRC_URI[perl-5.10.1.sha256sum] = "cb7f26ea4b2b28d6644354d87a269d01cac1b635287dae64e88eeafa24b44f35"