aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyserial_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pyserial_2.4.bb')
-rw-r--r--recipes/python/python-pyserial_2.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-pyserial_2.4.bb b/recipes/python/python-pyserial_2.4.bb
new file mode 100644
index 0000000000..637a980e49
--- /dev/null
+++ b/recipes/python/python-pyserial_2.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Serial Port Support for Python"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+SRCNAME = "pyserial"
+PR = "ml1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+# FIXME might stop packaging serialwin32 and serialjava files
+
+RDEPENDS = "\
+ python-fcntl \
+ python-io \
+ python-stringold \
+"