aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/quake/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/quake/files')
-rw-r--r--recipes/quake/files/Makefile.patch10
-rw-r--r--recipes/quake/files/cl_parse.c.patch42
-rw-r--r--recipes/quake/files/host.c.patch29
-rw-r--r--recipes/quake/files/vid_sdl.c.patch11
4 files changed, 92 insertions, 0 deletions
diff --git a/recipes/quake/files/Makefile.patch b/recipes/quake/files/Makefile.patch
new file mode 100644
index 0000000000..ba2c6cf997
--- /dev/null
+++ b/recipes/quake/files/Makefile.patch
@@ -0,0 +1,10 @@
+--- quake1src/Makefile~ 2004-10-07 14:29:11.000000000 +0100
++++ quake1src/Makefile 2005-05-06 16:04:50.808451944 +0100
+@@ -97,7 +92,6 @@
+ r_misc.o \
+ snd_mix.o \
+ wad.o \
+- cd_sdl.o \
+ crc.o \
+ d_sprite.o \
+ model.o \
diff --git a/recipes/quake/files/cl_parse.c.patch b/recipes/quake/files/cl_parse.c.patch
new file mode 100644
index 0000000000..a233d608a4
--- /dev/null
+++ b/recipes/quake/files/cl_parse.c.patch
@@ -0,0 +1,42 @@
+--- quake1src/cl_parse.c~ 2003-09-09 14:30:55.000000000 +0100
++++ quake1src/cl_parse.c 2005-05-06 16:02:13.228407752 +0100
+@@ -898,14 +898,14 @@
+
+ if (cl.paused)
+ {
+- CDAudio_Pause ();
++// CDAudio_Pause ();
+ #ifdef _WIN32
+ VID_HandlePause (true);
+ #endif
+ }
+ else
+ {
+- CDAudio_Resume ();
++// CDAudio_Resume ();
+ #ifdef _WIN32
+ VID_HandlePause (false);
+ #endif
+@@ -940,14 +940,14 @@
+ CL_ParseStaticSound ();
+ break;
+
+- case svc_cdtrack:
+- cl.cdtrack = MSG_ReadByte ();
+- cl.looptrack = MSG_ReadByte ();
+- if ( (cls.demoplayback || cls.demorecording) && (cls.forcetrack != -1) )
+- CDAudio_Play ((byte)cls.forcetrack, true);
+- else
+- CDAudio_Play ((byte)cl.cdtrack, true);
+- break;
++ case svc_cdtrack:
++ cl.cdtrack = MSG_ReadByte ();
++ cl.looptrack = MSG_ReadByte ();
++// if ( (cls.demoplayback || cls.demorecording) && (cls.forcetrack != -1) )
++// CDAudio_Play ((byte)cls.forcetrack, true);
++// else
++// CDAudio_Play ((byte)cl.cdtrack, true);
++ break;
+
+ case svc_intermission:
+ cl.intermission = 1;
diff --git a/recipes/quake/files/host.c.patch b/recipes/quake/files/host.c.patch
new file mode 100644
index 0000000000..e5e6457241
--- /dev/null
+++ b/recipes/quake/files/host.c.patch
@@ -0,0 +1,29 @@
+--- quake1src/host.c~ 2003-09-09 13:59:53.000000000 +0100
++++ quake1src/host.c 2005-05-06 16:13:50.193452960 +0100
+@@ -874,7 +874,7 @@
+ else
+ S_Update (vec3_origin, vec3_origin, vec3_origin, vec3_origin);
+
+- CDAudio_Update();
++// CDAudio_Update();
+
+ if (host_speeds.value)
+ {
+@@ -1074,7 +1074,7 @@
+ #endif
+
+ #endif // _WIN32
+- CDAudio_Init ();
++// CDAudio_Init ();
+ Sbar_Init ();
+ CL_Init ();
+ #ifdef _WIN32 // on non win32, mouse comes before video for security reasons
+@@ -1117,7 +1117,7 @@
+
+ Host_WriteConfiguration ();
+
+- CDAudio_Shutdown ();
++// CDAudio_Shutdown ();
+ NET_Shutdown ();
+ S_Shutdown();
+ IN_Shutdown ();
diff --git a/recipes/quake/files/vid_sdl.c.patch b/recipes/quake/files/vid_sdl.c.patch
new file mode 100644
index 0000000000..17d58d8164
--- /dev/null
+++ b/recipes/quake/files/vid_sdl.c.patch
@@ -0,0 +1,11 @@
+--- quake1src/vid_sdl.c~ 2003-09-24 02:18:50.000000000 +0100
++++ quake1src/vid_sdl.c 2005-05-08 15:30:10.663089128 +0100
+@@ -59,7 +59,7 @@
+ Uint32 flags;
+
+ // Load the SDL library
+- if (SDL_Init(SDL_INIT_VIDEO|SDL_INIT_AUDIO|SDL_INIT_CDROM) < 0)
++ if (SDL_Init(SDL_INIT_VIDEO|SDL_INIT_AUDIO) < 0)
+ Sys_Error("VID: Couldn't load SDL: %s", SDL_GetError());
+
+ // Set up display mode (width and height)