aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rpm/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rpm/files')
-rw-r--r--recipes/rpm/files/cross_libpaths.patch24
-rw-r--r--recipes/rpm/files/fix_mypath.patch13
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/rpm/files/cross_libpaths.patch b/recipes/rpm/files/cross_libpaths.patch
new file mode 100644
index 0000000000..d6139dbdde
--- /dev/null
+++ b/recipes/rpm/files/cross_libpaths.patch
@@ -0,0 +1,24 @@
+Index: rpm-4.4/configure.ac
+===================================================================
+--- rpm-4.4.orig/configure.ac 2005-01-29 10:54:37.698359056 -0500
++++ rpm-4.4/configure.ac 2005-01-29 10:55:16.492461456 -0500
+@@ -321,10 +321,8 @@
+
+ localdone=
+
+-dirs=$prefix
+ if test "$cross_compiling" != "yes"; then
+- dirs="$dirs /usr/local"
+-fi
++dirs="$prefix /usr/local"
+ for dir in $dirs
+ do
+ case $dir in
+@@ -366,6 +364,7 @@
+ else
+ AC_MSG_RESULT(no)
+ fi
++fi
+
+ dnl
+ dnl Check for features
diff --git a/recipes/rpm/files/fix_mypath.patch b/recipes/rpm/files/fix_mypath.patch
new file mode 100644
index 0000000000..09512be131
--- /dev/null
+++ b/recipes/rpm/files/fix_mypath.patch
@@ -0,0 +1,13 @@
+Index: rpm-4.4/configure.ac
+===================================================================
+--- rpm-4.4.orig/configure.ac 2005-01-29 10:54:13.599022712 -0500
++++ rpm-4.4/configure.ac 2005-01-29 10:54:37.698359056 -0500
+@@ -230,7 +230,7 @@
+ dnl use defaults if cross-compiling, otherwise use the default path.
+ dnl
+ if test "$cross_compiling" = "yes"; then
+- MYPATH=""
++ MYPATH=":"
+ else
+ # MYPATH="/bin:/usr/bin:/usr/local/bin:$PATH:/sbin:/usr/sbin:/usr/local/sbin:/opt/gnu/bin"
+ MYPATH=$PATH