aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xcursor-transparent-theme
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xcursor-transparent-theme')
-rw-r--r--recipes/xcursor-transparent-theme/files/fix_watch_cursor.patch24
-rw-r--r--recipes/xcursor-transparent-theme/files/use-relative-symlinks.patch11
-rw-r--r--recipes/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb13
-rwxr-xr-xrecipes/xcursor-transparent-theme/xcursor-watchonly-theme/20xcursor-transparent7
-rw-r--r--recipes/xcursor-transparent-theme/xcursor-watchonly-theme/skip_watch_cursor.patch23
-rw-r--r--recipes/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb23
6 files changed, 101 insertions, 0 deletions
diff --git a/recipes/xcursor-transparent-theme/files/fix_watch_cursor.patch b/recipes/xcursor-transparent-theme/files/fix_watch_cursor.patch
new file mode 100644
index 0000000000..73a5b2a87a
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/files/fix_watch_cursor.patch
@@ -0,0 +1,24 @@
+diff -NurP xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.am xcursor-transparent-theme-0.1.1/cursors/Makefile.am
+--- xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.am 2003-10-30 13:13:59.000000000 +0100
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2005-12-20 23:35:17.000000000 +0100
+@@ -79,7 +79,7 @@
+ ul_angle \
+ ur_angle \
+ v_double_arrow \
+- watcha \
++ watch \
+ xterm
+
+ CURSOR_DIR = $(datadir)/icons/xcursor-transparent/cursors
+diff -NurP xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.in xcursor-transparent-theme-0.1.1/cursors/Makefile.in
+--- xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.in 2003-10-31 15:31:13.000000000 +0100
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.in 2005-12-20 23:35:36.000000000 +0100
+@@ -67,7 +67,7 @@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+
+-CURSOR_NAMES = 00008160000006810000408080010102 028006030e0e7ebffc7f7070c0600140 03b6e0fcb3499374a867c041f52298f0 08e8e1c95fe2fc01f976f1e063a24ccd 14fef782d02440884392942c11205230 2870a09082c103050810ffdffffe0204 3ecb610c1bf2410f44200f48c40d3599 4498f0e0c1937ffe01fd06f973665830 9d800788f1b08800ae810202380a0822 c7088f0f3e6c8088236ef8e1e3e70000 d9ce0ab605698f320427677b458ad60b e29285e634086352946a0e7090d73106 fcf1c3c7cd4491d801f1e1c78f100000 X_cursor arrow base_arrow_down base_arrow_up based_arrow_down based_arrow_up bd_double_arrow boat bottom_left_corner bottom_right_corner bottom_side bottom_tee center_ptr circle cross cross_reverse crossed_circle crosshair dot dot_box_mask dotbox double_arrow draft_large draft_small draped_box exchange fd_double_arrow fleur gumby h_double_arrow hand hand1 hand2 left_ptr left_ptr_watch left_side left_tee ll_angle lr_angle move pencil pirate plus question_arrow right_ptr right_side right_tee sailboat sb_down_arrow sb_h_double_arrow sb_left_arrow sb_right_arrow sb_up_arrow sb_v_double_arrow shuttle sizing target tcross top_left_arrow top_left_corner top_right_corner top_side top_tee trek ul_angle ur_angle v_double_arrow watcha xterm
++CURSOR_NAMES = 00008160000006810000408080010102 028006030e0e7ebffc7f7070c0600140 03b6e0fcb3499374a867c041f52298f0 08e8e1c95fe2fc01f976f1e063a24ccd 14fef782d02440884392942c11205230 2870a09082c103050810ffdffffe0204 3ecb610c1bf2410f44200f48c40d3599 4498f0e0c1937ffe01fd06f973665830 9d800788f1b08800ae810202380a0822 c7088f0f3e6c8088236ef8e1e3e70000 d9ce0ab605698f320427677b458ad60b e29285e634086352946a0e7090d73106 fcf1c3c7cd4491d801f1e1c78f100000 X_cursor arrow base_arrow_down base_arrow_up based_arrow_down based_arrow_up bd_double_arrow boat bottom_left_corner bottom_right_corner bottom_side bottom_tee center_ptr circle cross cross_reverse crossed_circle crosshair dot dot_box_mask dotbox double_arrow draft_large draft_small draped_box exchange fd_double_arrow fleur gumby h_double_arrow hand hand1 hand2 left_ptr left_ptr_watch left_side left_tee ll_angle lr_angle move pencil pirate plus question_arrow right_ptr right_side right_tee sailboat sb_down_arrow sb_h_double_arrow sb_left_arrow sb_right_arrow sb_up_arrow sb_v_double_arrow shuttle sizing target tcross top_left_arrow top_left_corner top_right_corner top_side top_tee trek ul_angle ur_angle v_double_arrow watch xterm
+
+
+ CURSOR_DIR = $(datadir)/icons/xcursor-transparent/cursors
diff --git a/recipes/xcursor-transparent-theme/files/use-relative-symlinks.patch b/recipes/xcursor-transparent-theme/files/use-relative-symlinks.patch
new file mode 100644
index 0000000000..df28dfbc88
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/files/use-relative-symlinks.patch
@@ -0,0 +1,11 @@
+diff -ur xcursor-transparent-theme-0.1.1~/cursors/Makefile.am xcursor-transparent-theme-0.1.1/cursors/Makefile.am
+--- xcursor-transparent-theme-0.1.1~/cursors/Makefile.am 2003-10-30 12:13:59.000000000 +0000
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2004-07-27 12:56:24.000000000 +0100
+@@ -91,6 +91,6 @@
+ $(INSTALL_DATA) $(CURSOR_REAL) $(DESTDIR)$(CURSOR_DIR)/
+ for CURSOR in $(CURSOR_NAMES); do \
+ echo '-- Installing cursor '$$CURSOR; \
+- ln -s $(DESTDIR)$(CURSOR_DIR)/transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
++ ln -s transp $(DESTDIR)$(CURSOR_DIR)/$$CURSOR; \
+ done
+
diff --git a/recipes/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb b/recipes/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
new file mode 100644
index 0000000000..e87a72ab19
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/xcursor-transparent-theme_0.1.1.bb
@@ -0,0 +1,13 @@
+LICENSE = "GPL"
+DESCRIPTION = "Transparent xcursor theme for handheld systems"
+SECTION = "x11/base"
+PR ="r2"
+
+SRC_URI = "http://matchbox-project.org/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
+ file://use-relative-symlinks.patch;patch=1 \
+ file://fix_watch_cursor.patch;patch=1"
+FILES_${PN} = "${datadir}/icons/xcursor-transparent/cursors/*"
+
+inherit autotools
+
+PACKAGE_ARCH = "all"
diff --git a/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/20xcursor-transparent b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/20xcursor-transparent
new file mode 100755
index 0000000000..6fa068214e
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/20xcursor-transparent
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# Only if there's no mouse at all, we use use transparent cursors
+# for stylus use comfort.
+if ! ls /dev/input/mouse* >/dev/null 2>&1; then
+ echo "Xcursor.theme: xcursor-transparent" | xrdb -merge -nocpp
+fi
diff --git a/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/skip_watch_cursor.patch b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/skip_watch_cursor.patch
new file mode 100644
index 0000000000..5c13fa885a
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme/skip_watch_cursor.patch
@@ -0,0 +1,23 @@
+diff -NurP xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.am xcursor-transparent-theme-0.1.1/cursors/Makefile.am
+--- xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.am 2003-10-30 13:13:59.000000000 +0100
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.am 2005-12-20 23:35:17.000000000 +0100
+@@ -79,7 +79,6 @@
+ ul_angle \
+ ur_angle \
+ v_double_arrow \
+- watcha \
+ xterm
+
+ CURSOR_DIR = $(datadir)/icons/xcursor-transparent/cursors
+diff -NurP xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.in xcursor-transparent-theme-0.1.1/cursors/Makefile.in
+--- xcursor-transparent-theme-0.1.1-orig/cursors/Makefile.in 2003-10-31 15:31:13.000000000 +0100
++++ xcursor-transparent-theme-0.1.1/cursors/Makefile.in 2005-12-20 23:35:36.000000000 +0100
+@@ -67,7 +67,7 @@
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+
+-CURSOR_NAMES = 00008160000006810000408080010102 028006030e0e7ebffc7f7070c0600140 03b6e0fcb3499374a867c041f52298f0 08e8e1c95fe2fc01f976f1e063a24ccd 14fef782d02440884392942c11205230 2870a09082c103050810ffdffffe0204 3ecb610c1bf2410f44200f48c40d3599 4498f0e0c1937ffe01fd06f973665830 9d800788f1b08800ae810202380a0822 c7088f0f3e6c8088236ef8e1e3e70000 d9ce0ab605698f320427677b458ad60b e29285e634086352946a0e7090d73106 fcf1c3c7cd4491d801f1e1c78f100000 X_cursor arrow base_arrow_down base_arrow_up based_arrow_down based_arrow_up bd_double_arrow boat bottom_left_corner bottom_right_corner bottom_side bottom_tee center_ptr circle cross cross_reverse crossed_circle crosshair dot dot_box_mask dotbox double_arrow draft_large draft_small draped_box exchange fd_double_arrow fleur gumby h_double_arrow hand hand1 hand2 left_ptr left_ptr_watch left_side left_tee ll_angle lr_angle move pencil pirate plus question_arrow right_ptr right_side right_tee sailboat sb_down_arrow sb_h_double_arrow sb_left_arrow sb_right_arrow sb_up_arrow sb_v_double_arrow shuttle sizing target tcross top_left_arrow top_left_corner top_right_corner top_side top_tee trek ul_angle ur_angle v_double_arrow watcha xterm
++CURSOR_NAMES = 00008160000006810000408080010102 028006030e0e7ebffc7f7070c0600140 03b6e0fcb3499374a867c041f52298f0 08e8e1c95fe2fc01f976f1e063a24ccd 14fef782d02440884392942c11205230 2870a09082c103050810ffdffffe0204 3ecb610c1bf2410f44200f48c40d3599 4498f0e0c1937ffe01fd06f973665830 9d800788f1b08800ae810202380a0822 c7088f0f3e6c8088236ef8e1e3e70000 d9ce0ab605698f320427677b458ad60b e29285e634086352946a0e7090d73106 fcf1c3c7cd4491d801f1e1c78f100000 X_cursor arrow base_arrow_down base_arrow_up based_arrow_down based_arrow_up bd_double_arrow boat bottom_left_corner bottom_right_corner bottom_side bottom_tee center_ptr circle cross cross_reverse crossed_circle crosshair dot dot_box_mask dotbox double_arrow draft_large draft_small draped_box exchange fd_double_arrow fleur gumby h_double_arrow hand hand1 hand2 left_ptr left_ptr_watch left_side left_tee ll_angle lr_angle move pencil pirate plus question_arrow right_ptr right_side right_tee sailboat sb_down_arrow sb_h_double_arrow sb_left_arrow sb_right_arrow sb_up_arrow sb_v_double_arrow shuttle sizing target tcross top_left_arrow top_left_corner top_right_corner top_side top_tee trek ul_angle ur_angle v_double_arrow xterm
+
+
+ CURSOR_DIR = $(datadir)/icons/xcursor-transparent/cursors
diff --git a/recipes/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb
new file mode 100644
index 0000000000..c1fad3aeed
--- /dev/null
+++ b/recipes/xcursor-transparent-theme/xcursor-watchonly-theme_0.1.1.bb
@@ -0,0 +1,23 @@
+LICENSE = "GPL"
+DESCRIPTION = "Transparent xcursor theme for handheld systems with visible watch cursor"
+SECTION = "x11/base"
+RREPLACES = "xcursor-transparent-theme"
+RPROVIDES = "xcursor-transparent-theme"
+PR ="r4"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/utils/xcursor-transparent-theme-${PV}.tar.gz \
+ file://use-relative-symlinks.patch;patch=1 \
+ file://skip_watch_cursor.patch;patch=1 \
+ file://20xcursor-transparent"
+S = "${WORKDIR}/xcursor-transparent-theme-${PV}"
+
+FILES_${PN} += "${datadir}/icons/xcursor-transparent/cursors/*"
+
+inherit autotools
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/X11/Xsession.d
+ install -m 0755 ${WORKDIR}/20xcursor-transparent ${D}${sysconfdir}/X11/Xsession.d
+}
+
+PACKAGE_ARCH = "all"