aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xmame/xmame_0.86.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xmame/xmame_0.86.bb')
-rw-r--r--recipes/xmame/xmame_0.86.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/xmame/xmame_0.86.bb b/recipes/xmame/xmame_0.86.bb
new file mode 100644
index 0000000000..a5801e73da
--- /dev/null
+++ b/recipes/xmame/xmame_0.86.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Multiple Arcade Machine Emulator based on SDL"
+LICENSE = "xmame"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "expat virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://x.mame.net/download/historic/${P}.tar.bz2 \
+ file://${FILESDIR}/crosscompile.patch;patch=1"
+
+inherit flow-lossage
+
+EXTRA_OEMAKE=
+
+do_compile() {
+ oe_runmake TARGET=mame JOY_SDL=1 SOUND_SDL=1 DISPLAY_METHOD=SDL \
+ CC="${CC}" CXX="${CXX}" CFLAGS="-I. -Isrc -Isrc/include -Isrc/unix ${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}" \
+ RANLIB="${RANLIB}" MY_CPU="${TARGET_ARCH}" ARCH="${TARGET_OS}" \
+ GLLIBS="" STRIP="${STRIP}" AR="${AR}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 xmame.SDL ${D}${bindir}
+}
+