aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-03-17 13:26:19 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2023-03-17 17:43:06 +0100
commit3bfb8acb402f6976d3ae33114233510ffd6ccbcc (patch)
tree56083d7a88f16e9162c0808fdb2a570d4a58158f
parent1f0e2f69ac43bba76674be41cf205d4f3c37df55 (diff)
downloadmeta-openembedded-contrib-jansa/webrtc.tar.gz
WIP: pipewire: accept webrtc-audio-processing-1jansa/webrtc
This isn't complete still fails with: http://errors.yoctoproject.org/Errors/Details/698127/ and after fixing this include (by dropping webrtc prefix), the other 2 includes don't exist anymore as well and fails with: http://errors.yoctoproject.org/Errors/Details/698129/ FAILED: spa/plugins/aec/libspa-aec-webrtc.so.p/aec-webrtc.cpp.o x86_64-oe-linux-g++ -m64 -march=core2 -mtune=core2 -msse3 -mfpmath=sse -fstack-protector-strong -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -Werror=format-security --sysroot=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/recipe-sysroot -Ispa/plugins/aec/libspa-aec-webrtc.so.p -Ispa/plugins/aec -I../git/spa/plugins/aec -I. -I../git -Ispa/include -I../git/spa/include -ITOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/recipe-sysroot/usr/include/webrtc-audio-processing-1 -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -Wpedantic -std=c++17 -fvisibility=hidden -fno-strict-aliasing -Werror=suggest-attribute=format -Wsign-compare -Wpointer-arith -Wformat -Wformat-security -Wimplicit-fallthrough -Wmissing-braces -Wtype-limits -Wvariadic-macros -Wmaybe-uninitialized -Wno-missing-field-initializers -Wno-unused-parameter -Wno-pedantic -Wdeprecated-declarations -Wunused-result -O2 -pipe -g -feliminate-unused-debug-types -fmacro-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/git=/usr/src/debug/pipewire/0.3.67-r0 -fdebug-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/git=/usr/src/debug/pipewire/0.3.67-r0 -fmacro-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/build=/usr/src/debug/pipewire/0.3.67-r0 -fdebug-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/build=/usr/src/debug/pipewire/0.3.67-r0 -fdebug-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/recipe-sysroot= -fmacro-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/recipe-sysroot= -fdebug-prefix-map=TOPDIR/tmp-glibc/work/core2-64-oe-linux/pipewire/0.3.67-r0/recipe-sysroot-native= -fvisibility-inlines-hidden -fPIC -DWEBRTC_LIBRARY_IMPL -DWEBRTC_POSIX -DNOMINMAX -MD -MQ spa/plugins/aec/libspa-aec-webrtc.so.p/aec-webrtc.cpp.o -MF spa/plugins/aec/libspa-aec-webrtc.so.p/aec-webrtc.cpp.o.d -o spa/plugins/aec/libspa-aec-webrtc.so.p/aec-webrtc.cpp.o -c ../git/spa/plugins/aec/aec-webrtc.cpp ../git/spa/plugins/aec/aec-webrtc.cpp: In function 'int webrtc_init(void*, const spa_dict*, const spa_audio_info_raw*)': ../git/spa/plugins/aec/aec-webrtc.cpp:64:28: error: 'ExtendedFilter' is not a member of 'webrtc' 64 | config.Set<webrtc::ExtendedFilter>(new webrtc::ExtendedFilter(extended_filter)); | ^~~~~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:64:48: error: expected type-specifier 64 | config.Set<webrtc::ExtendedFilter>(new webrtc::ExtendedFilter(extended_filter)); | ^~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:65:28: error: 'DelayAgnostic' is not a member of 'webrtc' 65 | config.Set<webrtc::DelayAgnostic>(new webrtc::DelayAgnostic(delay_agnostic)); | ^~~~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:65:47: error: expected type-specifier 65 | config.Set<webrtc::DelayAgnostic>(new webrtc::DelayAgnostic(delay_agnostic)); | ^~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:76:86: error: 'Create' is not a member of 'webrtc::AudioProcessing' 76 | auto apm = std::unique_ptr<webrtc::AudioProcessing>(webrtc::AudioProcessing::Create(config)); | ^~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:88:65: error: 'webrtc::EchoCancellation' has not been declared 88 | apm->echo_cancellation()->set_suppression_level(webrtc::EchoCancellation::kHighSuppression); | ^~~~~~~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:89:53: error: 'webrtc::NoiseSuppression' has not been declared 89 | apm->noise_suppression()->set_level(webrtc::NoiseSuppression::kHigh); | ^~~~~~~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:94:47: error: 'webrtc::GainControl' has not been declared 94 | apm->gain_control()->set_mode(webrtc::GainControl::kAdaptiveDigital); | ^~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:45:14: warning: unused variable 'extended_filter' [-Wunused-variable] 45 | bool extended_filter = webrtc_get_spa_bool(args, "webrtc.extended_filter", true); | ^~~~~~~~~~~~~~~ ../git/spa/plugins/aec/aec-webrtc.cpp:46:14: warning: unused variable 'delay_agnostic' [-Wunused-variable] 46 | bool delay_agnostic = webrtc_get_spa_bool(args, "webrtc.delay_agnostic", true); | ^~~~~~~~~~~~~~ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-meson.build-accept-webrtc-audio-processing-1.patch24
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.67.bb4
2 files changed, 27 insertions, 1 deletions
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-meson.build-accept-webrtc-audio-processing-1.patch b/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-meson.build-accept-webrtc-audio-processing-1.patch
new file mode 100644
index 0000000000..f5567c3def
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire/0001-meson.build-accept-webrtc-audio-processing-1.patch
@@ -0,0 +1,24 @@
+From 759dc6eb1eac0b6eec125a19787ae2d324edb9b4 Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Fri, 17 Mar 2023 13:24:03 +0100
+Subject: [PATCH] meson.build: accept webrtc-audio-processing-1
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ meson.build | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 9d5e3a17b..0a669f971 100644
+--- a/meson.build
++++ b/meson.build
+@@ -358,8 +358,7 @@ summary({'gstreamer-device-provider': gst_dp_found}, bool_yn: true, section: 'Ba
+
+ cdata.set('HAVE_GSTREAMER_DEVICE_PROVIDER', get_option('gstreamer-device-provider').allowed())
+
+-webrtc_dep = dependency('webrtc-audio-processing',
+- version : ['>= 0.2', '< 1.0'],
++webrtc_dep = dependency('webrtc-audio-processing-1',
+ required : get_option('echo-cancel-webrtc'))
+ summary({'WebRTC Echo Canceling': webrtc_dep.found()}, bool_yn: true, section: 'Misc dependencies')
+ cdata.set('HAVE_WEBRTC', webrtc_dep.found())
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.67.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.67.bb
index b6d58da347..3473984947 100644
--- a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.67.bb
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.67.bb
@@ -14,7 +14,9 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "dbus ncurses"
SRCREV = "26623ff8cb3c9ba774537379a1835c5efb0d5159"
-SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
+SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https \
+ file://0001-meson.build-accept-webrtc-audio-processing-1.patch \
+"
S = "${WORKDIR}/git"