aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-08-25 04:22:05 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-08-25 15:32:17 +1200
commit66e9dbc5db329448c756cf59d2a00273e99382ba (patch)
tree0cddb15df9556404bcd1b9ee427d39addccb1d1d
parent8fa8e493475e7a261aa75ee0652218d272c00e39 (diff)
downloadmeta-openembedded-contrib-paule/python-paho-mqtt-fixes.tar.gz
python-paho-mqtt: fix downloading during do_compilepaule/python-paho-mqtt-fixes
During do_compile if setup.py finds that pytest-runner - which is declared as a setup dependency in setup.py - isn't available it was attempting to download it from pypi, which is problematic if you are behind a proxy because the environment for do_compile isn't set up for that. Add an appropriate native dependency to prevent this situation. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--meta-python/recipes-devtools/python/python-paho-mqtt.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-paho-mqtt.inc b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
index 6cbde74cb4..ad1ce6a90f 100644
--- a/meta-python/recipes-devtools/python/python-paho-mqtt.inc
+++ b/meta-python/recipes-devtools/python/python-paho-mqtt.inc
@@ -10,6 +10,8 @@ inherit pypi
SRC_URI[md5sum] = "b9338236e2836e8579ef140956189cc4"
SRC_URI[sha256sum] = "2c9ef5494cfc1e41a9fff6544c5a2cd59ea5d401d9119a06ecf7fad6a2ffeb93"
+DEPENDS += "${PYTHON_PN}-pytest-runner-native"
+
RDEPENDS_${PN} = "\
${PYTHON_PN}-math \
${PYTHON_PN}-io \