aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-09-26 15:39:00 +1300
committerPaul Eggleton <paul.eggleton@linux.intel.com>2017-09-27 00:11:09 +1300
commit1fdecc334ec50875786acd2a50a4cb45ebd05b63 (patch)
treef4e80fdcee80f106910401fbc7a2fd5475b951ad
parentf841648657069051dffa1012a42eb1524b894d50 (diff)
downloadmeta-openembedded-contrib-paule/python-pyfirmata.tar.gz
python-pyfirmata: move in from meta-intel-iot-middleware and upgradepaule/python-pyfirmata
The following improvements have been made over the recipe that was in meta-intel-iot-middleware (a layer which is no longer actively maintained): * Upgrade to 1.0.3 * Inherit from setuptools instead of distutils since that changed with the upgrade * Inherit pypi and also provide Python 3 version * Use the correct LICENSE (changed BSD -> MIT back at version 0.9.5) * Set short description in SUMMARY instead of DESCRIPTION Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pyfirmata.inc13
-rw-r--r--meta-python/recipes-devtools/python/python-pyfirmata_1.0.3.bb3
-rw-r--r--meta-python/recipes-devtools/python/python3-pyfirmata_1.0.3.bb3
3 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyfirmata.inc b/meta-python/recipes-devtools/python/python-pyfirmata.inc
new file mode 100644
index 0000000000..2365379aa2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyfirmata.inc
@@ -0,0 +1,13 @@
+SUMMARY = "A Python interface for the Firmata protocol"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84ddcef430b7c44caa22b2ff4b37a3df"
+PYPI_PACKAGE = "pyFirmata"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-pyserial \
+"
+
+SRC_URI[md5sum] = "ee4c23ca5c35d3091d550a63540811a3"
+SRC_URI[sha256sum] = "b54d49d66a9d93c1ef9c72ca01264414cb2de177baac116c12d5cce0c380160c"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pyfirmata_1.0.3.bb b/meta-python/recipes-devtools/python/python-pyfirmata_1.0.3.bb
new file mode 100644
index 0000000000..d77e0f3853
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyfirmata_1.0.3.bb
@@ -0,0 +1,3 @@
+inherit setuptools
+require python-pyfirmata.inc
+
diff --git a/meta-python/recipes-devtools/python/python3-pyfirmata_1.0.3.bb b/meta-python/recipes-devtools/python/python3-pyfirmata_1.0.3.bb
new file mode 100644
index 0000000000..25af1b5c0a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyfirmata_1.0.3.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-pyfirmata.inc
+