aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-16 21:39:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-17 17:09:41 +0100
commit4cbcd53f97d306b540e3d5e5ea9ca4e4e798e516 (patch)
tree4e07fb7a9fcd7cce0f3a1cf21ac244647916c761
parentd4d974484097cd13b7f94b8faa3d6b52c3939a45 (diff)
downloadmeta-openembedded-contrib-shr.tar.gz
azy: rename lemon provided by azy-native to azy_lemonshr
* meta-openembedded/meta-oe/recipes-devtools/lemon/lemon_3.5.4.bb provides almost the same lemon but lemon.c in azy sources is a bit modified (and completely reformatted :/) * rename it to resolve: WARNING: The recipe azy-native is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/lemon Matched in manifest-x86_64-lemon-native Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-efl/recipes-efl/efl/azy_svn.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-efl/recipes-efl/efl/azy_svn.bb b/meta-efl/recipes-efl/efl/azy_svn.bb
index 43f9b7df99..80821964c6 100644
--- a/meta-efl/recipes-efl/efl/azy_svn.bb
+++ b/meta-efl/recipes-efl/efl/azy_svn.bb
@@ -5,7 +5,7 @@ LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
PV = "1.0.0+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
SRCREV = "${EFL_SRCREV}"
@@ -15,14 +15,14 @@ BBCLASSEXTEND = "native"
EXTRA_OECONF += " --disable-mysql-tests"
do_configure_prepend_class-target() {
- sed -i "s#\./lemon#${STAGING_BINDIR_NATIVE}/lemon#g" ${S}/src/bin/Makefile.am
+ sed -i "s#\./lemon#${STAGING_BINDIR_NATIVE}/azy_lemon#g" ${S}/src/bin/Makefile.am
sed -i "s#\$(top_builddir)/src/bin/azy_parser -H -p -o#${STAGING_BINDIR_NATIVE}/azy_parser -H -p -o#g" ${S}/src/tests/Makefile.am
sed -i "s#\$(top_builddir)/src/bin/azy_parser -eHn -m#${STAGING_BINDIR_NATIVE}/azy_parser -eHn -m#g" ${S}/src/tests/identi.ca/Makefile.am
}
do_install_append_class-native() {
install -d ${D}/${bindir}
- install -m 0755 ${S}/src/bin/lemon ${D}/${bindir}
+ install -m 0755 ${S}/src/bin/lemon ${D}/${bindir}/azy_lemon
}
inherit efl