aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-16 01:29:41 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2019-06-16 01:56:30 -0700
commit042bbc6550b2eba752b88566e9d7e7fab81aace4 (patch)
treebc8fcbecd6a1d6f7efc8aa4ac4f3d521ff322474
parente91daf62528ba04d7a6ce6af06d0d0ca4a972281 (diff)
downloadmeta-openembedded-contrib-timo/perl-upgrades-06152019.tar.gz
libnet-ldap-perl: upgrade 0.65 -> 0.66; enable ptesttimo/perl-upgrades-06152019
* Add runtime dependencies * Add ptest dependencies Upstream release notes: 0.66 -- Tue Apr 16 11:23:55 CEST 2019 Enhancements * Entry.pm: accept more options in ldif() * inc/: refresh install tools * contrib/ldifsort: new option -h * documentation extensions * typo fixes Bug Fixes * contrib/schema2ad: fix syntax calculation * Refresh.pm: fix get_ttl() method * DSML: fix detection of auxiliary object classes Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.66.bb (renamed from meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.65.bb)26
1 files changed, 21 insertions, 5 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.65.bb b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.66.bb
index f2b1f1634d..26c7c389d8 100644
--- a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.65.bb
+++ b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.66.bb
@@ -9,21 +9,37 @@ SECTION = "libs"
LICENSE = "Artistic-1.0|GPLv1+"
LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e"
-SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
-SRC_URI[md5sum] = "d057c8db76913d95c0e460c7bdd98b27"
-SRC_URI[sha256sum] = "5f57dd261dc16ebf942a272ddafe69526598df71151a51916edc37a4f2f23834"
+SRC_URI[md5sum] = "c4c1ae9299cd488e75c1b82904458bef"
+SRC_URI[sha256sum] = "09263ce6166e80c98d689d41d09995b813389fd069b784601f6dc57f8e2b4102"
S = "${WORKDIR}/perl-ldap-${PV}"
-inherit cpan
+inherit cpan ptest-perl
do_configure_prepend() {
perl -pi -e 's/auto_install_now.*//g' Makefile.PL
}
-RDEPENDS_${PN} = "perl \
+do_install_ptest() {
+ cp -r ${B}/data ${D}${PTEST_PATH}
+ chown -R root:root ${D}${PTEST_PATH}
+}
+
+RDEPENDS_${PN} += " \
libconvert-asn1-perl \
libio-socket-ssl-perl \
libauthen-sasl-perl \
+ perl-module-integer \
"
+
+RDEPENDS_${PN}-ptest += " \
+ libxml-sax-base-perl \
+ libxml-sax-writer-perl \
+ perl-module-file-compare \
+ perl-module-perlio \
+ perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native"