aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 12:38:37 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 15:28:56 -0800
commitb82ce5fb3a9ad57e815590d3688998a4c8bbd5b8 (patch)
tree82bbc286f0addbcef9778cf1544c5d21c0c20fde
parent558e9c55f5534f1cd79bfb75954dea87eb4c7e85 (diff)
downloadmeta-openembedded-contrib-timo/ptest-pytest-automake.tar.gz
python3-pylint: switch to pytest --automaketimo/ptest-pytest-automake
* Also replace ${PYTHON_PN} with python3 * Sort all REDEPENDS alphabetically * Drop trailing whitespace Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb56
2 files changed, 30 insertions, 28 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint/run-ptest b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
index 2a4e87e03a..ed424cb879 100644
--- a/meta-python/recipes-devtools/python/python3-pylint/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-pylint/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest --benchmark-disable -vv --minimal-messages-config tests/test_functional.py | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --benchmark-disable -vv --minimal-messages-config --automake tests/test_functional.py
diff --git a/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
index cc33edd829..eb4b9e897f 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.3.bb
@@ -10,34 +10,36 @@ SRCREV = "1a5ffc1f447b77071ffe18a9c6836c09147ee2ed"
inherit python_setuptools_build_meta ptest
-RDEPENDS:${PN} += "${PYTHON_PN}-astroid \
- ${PYTHON_PN}-dill \
- ${PYTHON_PN}-isort \
- ${PYTHON_PN}-mccabe \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-platformdirs \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-json \
- ${PYTHON_PN}-pkgutil \
- ${PYTHON_PN}-difflib \
- ${PYTHON_PN}-netserver \
- ${PYTHON_PN}-tomlkit \
- "
+RDEPENDS:${PN} += "\
+ python3-astroid \
+ python3-difflib \
+ python3-dill \
+ python3-isort \
+ python3-json \
+ python3-mccabe \
+ python3-netserver \
+ python3-numbers \
+ python3-pkgutil \
+ python3-platformdirs \
+ python3-shell \
+ python3-tomlkit \
+ "
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-core \
- ${PYTHON_PN}-git \
- ${PYTHON_PN}-py \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytest-benchmark \
- ${PYTHON_PN}-pytest-runner \
- ${PYTHON_PN}-pytest-timeout \
- ${PYTHON_PN}-pytest-xdist \
- ${PYTHON_PN}-requests \
- ${PYTHON_PN}-statistics \
- ${PYTHON_PN}-tomllib \
- ${PYTHON_PN}-typing-extensions \
- "
+ python3-core \
+ python3-git \
+ python3-py \
+ python3-pytest \
+ python3-pytest-benchmark \
+ python3-pytest-runner \
+ python3-pytest-timeout \
+ python3-pytest-xdist \
+ python3-requests \
+ python3-statistics \
+ python3-tomllib \
+ python3-typing-extensions \
+ python3-unittest-automake-output \
+ "
S = "${WORKDIR}/git"
@@ -46,7 +48,7 @@ do_install_ptest() {
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
- # regression_distutil_import_error_73.py fails to run see
+ # regression_distutil_import_error_73.py fails to run see
# https://lists.openembedded.org/g/openembedded-devel/topic/103181847
rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
}