aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-15 13:50:28 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-15 23:43:27 -0700
commitd57c4655623a7271dc93cfb741ffdbf1b511a5c2 (patch)
tree88ce40fcadc00ca8455abb70eed3a3c2cf4ad20c
parent29abcea7bb0cacfbc4f2281d296b286010e4a276 (diff)
downloadmeta-openembedded-contrib-d57c4655623a7271dc93cfb741ffdbf1b511a5c2.tar.gz
dhcp-relay: Pass cross configure flags to bind build
This ensures that host tools like 'gen' are built for build host and not target. internal bind build supplies its own options to configuring it, where it does not pass --host option and as a result it does not deduce it to be a cross compile and hence these variables are not set property inside bind build Fixes | ./gen: /usr/lib/libc.so.6: version `GLIBC_2.38' not found (required by ./gen) Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3p1.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3p1.bb b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3p1.bb
index d36646c0d7..e5f7e0334f 100644
--- a/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3p1.bb
+++ b/meta-networking/recipes-connectivity/dhcp/dhcp-relay_4.4.3p1.bb
@@ -34,7 +34,14 @@ SYSTEMD_AUTO_ENABLE:${PN} = "disable"
CFLAGS += "-D_GNU_SOURCE -fcommon"
LDFLAGS:append = " -pthread"
-EXTRA_OECONF = "--enable-paranoia \
+BIND_EXTRA_CONFIG = "\
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+"
+
+EXTRA_OECONF = "--with-bind-extra-config="${BIND_EXTRA_CONFIG}" \
+ --enable-paranoia \
--disable-static \
--enable-libtool \
--with-randomdev=/dev/random \