aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/obex
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-19 18:59:30 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-19 20:41:26 +0200
commit0839d07d6c97d6f979647cf6379ea1c6a3a58896 (patch)
treea801799d35fd9ace1c312fddc289ec1905ec576c /meta-oe/recipes-connectivity/obex
parentd413695d5e3faf48193fa9858b36d2830af64e2d (diff)
downloadmeta-openembedded-contrib-0839d07d6c97d6f979647cf6379ea1c6a3a58896.tar.gz
openobex 1.5: import from OE rev 58b79786c6b1ee26340b20e7606d2144f52543ed
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/obex')
-rw-r--r--meta-oe/recipes-connectivity/obex/openobex-1.5/disable-cable-test.patch16
-rw-r--r--meta-oe/recipes-connectivity/obex/openobex-1.5/libusb_crosscompile_check.patch11
-rw-r--r--meta-oe/recipes-connectivity/obex/openobex_1.5.bb33
3 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/obex/openobex-1.5/disable-cable-test.patch b/meta-oe/recipes-connectivity/obex/openobex-1.5/disable-cable-test.patch
new file mode 100644
index 0000000000..95b636dd8f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obex/openobex-1.5/disable-cable-test.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- openobex-1.2/apps/Makefile.am~disable-cable-test
++++ openobex-1.2/apps/Makefile.am
+@@ -6,7 +6,7 @@
+ obex_io.c obex_io.h \
+ obex_put_common.c obex_put_common.h
+
+-bin_PROGRAMS = irxfer obex_tcp irobex_palm3 obex_test
++bin_PROGRAMS = irxfer obex_tcp irobex_palm3
+
+ obex_test_SOURCES = \
+ obex_test.c obex_test.h \
diff --git a/meta-oe/recipes-connectivity/obex/openobex-1.5/libusb_crosscompile_check.patch b/meta-oe/recipes-connectivity/obex/openobex-1.5/libusb_crosscompile_check.patch
new file mode 100644
index 0000000000..1177dfeac9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obex/openobex-1.5/libusb_crosscompile_check.patch
@@ -0,0 +1,11 @@
+--- /tmp/acinclude.m4 2009-04-12 10:32:15.000000000 +0200
++++ openobex-1.5/acinclude.m4 2009-04-12 10:32:38.000000000 +0200
+@@ -158,7 +158,7 @@
+ ;;
+ *)
+ PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
++ REQUIRES="libusb"
+ ;;
+ esac
+ AC_SUBST(USB_CFLAGS)
diff --git a/meta-oe/recipes-connectivity/obex/openobex_1.5.bb b/meta-oe/recipes-connectivity/obex/openobex_1.5.bb
new file mode 100644
index 0000000000..66cc85dc14
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obex/openobex_1.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+DEPENDS = "virtual/libusb0 bluez4"
+LICENSE = "GPLv2 && LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
+ file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+ "
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
+ file://disable-cable-test.patch \
+ file://libusb_crosscompile_check.patch"
+
+SRC_URI[md5sum] = "0d83dc86445a46a1b9750107ba7ab65c"
+SRC_URI[sha256sum] = "e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+ --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+do_install_append() {
+ install -d ${D}${datadir}/aclocal
+ install -m 0644 ${S}/openobex.m4 ${D}${datadir}/aclocal
+}
+
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"
+