aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libreport/libreport_2.10.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-07-02 05:39:34 +0000
committerHongxu Jia <hongxu.jia@windriver.com>2019-07-02 16:10:57 +0800
commitab56d19838d836dafc57dd0c092781ae76a13866 (patch)
tree69ce3e156bcd0bed34da10a8ca1045a7a2ab7b46 /meta-oe/recipes-extended/libreport/libreport_2.10.0.bb
parent96c7f671cb019153edc03e0ab1ef873f0bb5efe9 (diff)
downloadmeta-openembedded-contrib-hongxu/upgrade-20190702.tar.gz
libreport: 2.9.7 -> 2.10.0hongxu/upgrade-20190702
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'meta-oe/recipes-extended/libreport/libreport_2.10.0.bb')
-rw-r--r--meta-oe/recipes-extended/libreport/libreport_2.10.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libreport/libreport_2.10.0.bb b/meta-oe/recipes-extended/libreport/libreport_2.10.0.bb
new file mode 100644
index 0000000000..e50226e276
--- /dev/null
+++ b/meta-oe/recipes-extended/libreport/libreport_2.10.0.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "Libraries providing API for reporting different problems in applications \
+to different bug targets like Bugzilla, ftp, trac, etc..."
+SUMMARY = "Generic library for reporting various problems"
+HOMEPAGE = "https://abrt.readthedocs.org/"
+LICENSE = "GPLv2+"
+DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
+ json-c libtar libnewt libproxy rpm \
+ augeas satyr systemd \
+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+
+SRC_URI = "git://github.com/abrt/libreport.git;protocol=https"
+SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
+ file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
+ file://0003-without-build-plugins.patch \
+ file://0004-configure.ac-remove-prog-test-of-augparse.patch \
+"
+SRCREV = "eaff08f38d771d9362923765bb404b1514c5ca0a"
+
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit distro_features_check
+REQUIRED_DISTRO_FEATURES = "systemd"
+
+inherit gettext autotools python3native pkgconfig
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
+PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
+
+EXTRA_OECONF += "--without-python2 --with-python3"
+
+RDEPENDS_python3-libreport += "${PN}"
+
+do_patch[prefuncs] += "do_gen_version"
+do_gen_version() {
+ cd ${S}
+ ./gen-version
+}
+
+PACKAGES += "python3-libreport"
+
+FILES_${PN} += "${datadir}/*"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
+FILES_python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"
+