aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2023-07-10 08:11:41 +0200
committerKhem Raj <raj.khem@gmail.com>2023-07-10 11:01:40 -0700
commit564af52a771d1454b4b859553a4bbbbc3dfe38ea (patch)
treea77e9e1a2eebdebb572ec42d411d7b16f7125471 /meta-oe/recipes-support
parentcd97171f02cd3103e27fc5219e5356be68a141be (diff)
downloadmeta-openembedded-contrib-564af52a771d1454b4b859553a4bbbbc3dfe38ea.tar.gz
spdlog: upgrade 1.11.0 -> 1.12.0
- remove unneeded patches Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog/0001-Do-not-use-LFS64-functions-on-linux-musl.patch30
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch44
-rw-r--r--meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb (renamed from meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb)7
3 files changed, 2 insertions, 79 deletions
diff --git a/meta-oe/recipes-support/spdlog/spdlog/0001-Do-not-use-LFS64-functions-on-linux-musl.patch b/meta-oe/recipes-support/spdlog/spdlog/0001-Do-not-use-LFS64-functions-on-linux-musl.patch
deleted file mode 100644
index b997389aa2..0000000000
--- a/meta-oe/recipes-support/spdlog/spdlog/0001-Do-not-use-LFS64-functions-on-linux-musl.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From ce7a593e74c8e0c2ece15c73e7614d4f13a19a53 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 30 Dec 2022 13:04:08 -0800
-Subject: [PATCH] Do not use LFS64 functions on linux/musl
-
-On musl, off_t is 64bit always ( even on 32bit platforms ), therefore using
-LFS64 funcitons is not needed on such platforms. Moreover, musl has stopped
-providing aliases for these functions [1] which means it wont compile on
-newer musl systems. Therefore only use it on 32bit glibc/linux platforms
-and exclude musl like cygwin or OSX
-
-[1] https://git.musl-libc.org/cgit/musl/commit/?id=246f1c811448f37a44b41cd8df8d0ef9736d95f4
-
-Upstream-Status: Submitted [https://github.com/gabime/spdlog/pull/2589]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- include/spdlog/details/os.h | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
---- a/include/spdlog/details/os-inl.h
-+++ b/include/spdlog/details/os-inl.h
-@@ -237,7 +237,7 @@ SPDLOG_INLINE size_t filesize(FILE *f)
- int fd = ::fileno(f);
- # endif
- // 64 bits(but not in osx or cygwin, where fstat64 is deprecated)
--# if (defined(__linux__) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
-+# if ((defined(__linux__) && defined(__GLIBC__)) || defined(__sun) || defined(_AIX)) && (defined(__LP64__) || defined(_LP64))
- struct stat64 st;
- if (::fstat64(fd, &st) == 0)
- {
diff --git a/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch b/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch
deleted file mode 100644
index c767db919f..0000000000
--- a/meta-oe/recipes-support/spdlog/spdlog/fix-build-for-master-fmt.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-Upstream-Status: Backport
-[https://github.com/gabime/spdlog/commit/0ca574ae168820da0268b3ec7607ca7b33024d05]
-
-Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
-
-From 0ca574ae168820da0268b3ec7607ca7b33024d05 Mon Sep 17 00:00:00 2001
-From: H1X4 <10332146+H1X4Dev@users.noreply.github.com>
-Date: Fri, 31 Mar 2023 20:39:32 +0300
-Subject: [PATCH] fix build for master fmt (non-bundled) (#2694)
-
-* fix build for master fmt (non-bundled)
-
-* update fmt_runtime_string macro
-
-* fix build of updated macro
----
- include/spdlog/common.h | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/include/spdlog/common.h b/include/spdlog/common.h
-index e69201a81..5f671c5c6 100644
---- a/include/spdlog/common.h
-+++ b/include/spdlog/common.h
-@@ -173,12 +173,19 @@ using format_string_t = fmt::format_string<Args...>;
- template<class T>
- using remove_cvref_t = typename std::remove_cv<typename std::remove_reference<T>::type>::type;
-
-+template <typename Char>
-+#if FMT_VERSION >= 90101
-+using fmt_runtime_string = fmt::runtime_format_string<Char>;
-+#else
-+using fmt_runtime_string = fmt::basic_runtime<Char>;
-+#endif
-+
- // clang doesn't like SFINAE disabled constructor in std::is_convertible<> so have to repeat the condition from basic_format_string here,
- // in addition, fmt::basic_runtime<Char> is only convertible to basic_format_string<Char> but not basic_string_view<Char>
- template<class T, class Char = char>
- struct is_convertible_to_basic_format_string
- : std::integral_constant<bool,
-- std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt::basic_runtime<Char>>::value>
-+ std::is_convertible<T, fmt::basic_string_view<Char>>::value || std::is_same<remove_cvref_t<T>, fmt_runtime_string<Char>>::value>
- {};
-
- # if defined(SPDLOG_WCHAR_FILENAMES) || defined(SPDLOG_WCHAR_TO_UTF8_SUPPORT)
diff --git a/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb b/meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb
index 2800be4784..c7d8ff8f3d 100644
--- a/meta-oe/recipes-support/spdlog/spdlog_1.11.0.bb
+++ b/meta-oe/recipes-support/spdlog/spdlog_1.12.0.bb
@@ -3,11 +3,8 @@ HOMEPAGE = "https://github.com/gabime/spdlog/wiki"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-SRCREV = "ad0e89cbfb4d0c1ce4d097e134eb7be67baebb36"
-SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x \
- file://0001-Do-not-use-LFS64-functions-on-linux-musl.patch \
- file://fix-build-for-master-fmt.patch \
- "
+SRCREV = "7e635fca68d014934b4af8a1cf874f63989352b7"
+SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x"
DEPENDS += "fmt"