aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-25 22:22:10 -0800
committerKhem Raj <raj.khem@gmail.com>2023-01-26 10:24:25 -0800
commit52837056555a45202742d338d365d06b4e2711bd (patch)
tree6f1213df3f12a42fbaadb8b21c87fcbedc976848 /meta-oe
parentd41cfd1d9a38fbabaa4b10801f8c17a2630acb55 (diff)
downloadmeta-openembedded-contrib-52837056555a45202742d338d365d06b4e2711bd.tar.gz
dbus-cxx: Fix build with gcc13
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb1
-rw-r--r--meta-oe/recipes-core/dbus-cxx/files/0001-Include-missing-cstdint.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
index 44804545de..bf1220788e 100644
--- a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
+++ b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
@@ -8,6 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4cf0188f02184e1e84b9586ac53c3f83"
SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
file://0001-Include-typeinfo-for-typeid.patch \
file://0001-include-utility-header.patch \
+ file://0001-Include-missing-cstdint.patch \
"
SRC_URI:append:libc-musl = " file://fix_build_musl.patch"
SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
diff --git a/meta-oe/recipes-core/dbus-cxx/files/0001-Include-missing-cstdint.patch b/meta-oe/recipes-core/dbus-cxx/files/0001-Include-missing-cstdint.patch
new file mode 100644
index 0000000000..4ad69eab42
--- /dev/null
+++ b/meta-oe/recipes-core/dbus-cxx/files/0001-Include-missing-cstdint.patch
@@ -0,0 +1,30 @@
+From 56e2cce87445d514c9992ecc19d03bb2115c82d6 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 25 Jan 2023 22:17:31 -0800
+Subject: [PATCH] Include missing <cstdint>
+
+gcc 13 moved some includes around and as a result <cstdint> is no longer transitively included [1]. Explicitly include it for uint{32,64}_t.
+
+[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+
+Upstream-Status: Submitted [https://github.com/dbus-cxx/dbus-cxx/pull/111]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ dbus-cxx/enums.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/dbus-cxx/enums.h b/dbus-cxx/enums.h
+index 8253a4b..c793fad 100644
+--- a/dbus-cxx/enums.h
++++ b/dbus-cxx/enums.h
+@@ -5,6 +5,7 @@
+ * *
+ * This file is part of the dbus-cxx library. *
+ ***************************************************************************/
++#include <cstdint>
+ #include <ostream>
+
+ #ifndef DBUSCXX_ENUMS_H
+--
+2.39.1
+