aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-01-11 15:29:50 -0800
committerTim Orling <tim.orling@konsulko.com>2022-01-15 20:47:31 -0800
commitae71fe15c5d6cb132ec20b3be0009b8146a37029 (patch)
tree316f8bdd1aada9fa1f35ed4d48eb1703eb441ac5 /meta-python/recipes-devtools/python/python3-cryptography/run-ptest
parentbe66b745dfd4b567f138bc1f6aa023f5c124ee61 (diff)
downloadmeta-openembedded-contrib-timo/python3-cryptography_36.0.1.tar.gz
python3-cryptography: upgrade 3.3.2 -> 36.0.1timo/python3-cryptography_36.0.1
See https://github.com/pyca/cryptography/blob/main/CHANGELOG.rst#3601---2021-12-14 for changes * Add PSF-2.0 license and explicitly add checksums for the LICENSE files that are packaged. * RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the patch for skipping. * Drop backported patch for openssl3 support. * inherit new setuptools_rust class (which inherits new pyo3 class, which inherits cargo and python3-dir). * RDEPENDS on python3-pytest-subtests for ptest * Copy pyproject.toml for ptest as it defines the pytest.marker(s) needed * Cleanup and alphabetize the RDEPENDS * Use 'cargo bitbake' to generate the crate:// SRC_URIs - Needed some hacks to the Cargo.toml in src/rust/ to make this work (probably only package.repository was strictly required): [package] description = "cryptography includes both high level recipes and low level interfaces to common cryptographic algorithms such as symmetric ciphers, message digests, and key derivation functions." homepage = "https://github.com/pyca/cryptography" repository = "https://github.com/pyca/cryptography" * Add patches to src/rust/Cargo.toml to fix cargo errors including pem version * Add check-memfree.py to ptest to check for sufficient free memory Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography/run-ptest')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/run-ptest4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
index 0ba239c2a4..1e97dda63e 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
@@ -1,2 +1,4 @@
#!/bin/sh
-py.test
+if ./check-memfree.py; then
+ pytest -vvvv tests/
+fi