aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gimp/mypaint
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gimp/mypaint')
-rw-r--r--meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch32
-rw-r--r--meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb8
-rw-r--r--meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb2
3 files changed, 38 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch b/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch
new file mode 100644
index 0000000000..28e279438a
--- /dev/null
+++ b/meta-gnome/recipes-gimp/mypaint/libmypaint/0001-make-build-compatible-w.-autoconf-2.7.patch
@@ -0,0 +1,32 @@
+From 712a101c9aa2eb8548e4d0100a4a2eaf76fad164 Mon Sep 17 00:00:00 2001
+From: Jesper Lloyd <jpl.lloyd@gmail.com>
+Date: Wed, 20 Jan 2021 20:21:53 +0100
+Subject: [PATCH] make build compatible w. autoconf 2.7
+
+Workaround for stricter behaviour (due to a bugfix) in 2.7,
+which makes a failing intltoolize macro check fail the build.
+
+Fix provided by hosiet.
+
+Upstream-Status: Backport [https://github.com/mypaint/libmypaint/commit/a6bac154db018e1f1cc4dbddc34f6c8422c891fb]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 416d9fe..48b9d02 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -248,7 +248,7 @@ if test "x$enable_i18n" != "xno"; then
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
+ [The prefix for our gettext translation domains.])
+ AC_SUBST(GETTEXT_PACKAGE)
+- IT_PROG_INTLTOOL
++IT_PROG_INTLTOOL
+ AM_GLIB_GNU_GETTEXT
+
+ dnl Debian: stdlib
+--
+2.30.0
+
diff --git a/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb b/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
index 37d41780d2..d509aa3dd0 100644
--- a/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
+++ b/meta-gnome/recipes-gimp/mypaint/libmypaint_git.bb
@@ -10,14 +10,16 @@ DEPENDS = " \
json-c \
"
-inherit autotools gobject-introspection gettext python3native
+inherit autotools gobject-introspection gettext pkgconfig python3native
-SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1"
+SRC_URI = "git://github.com/mypaint/libmypaint.git;protocol=https;branch=libmypaint-v1 \
+ file://0001-make-build-compatible-w.-autoconf-2.7.patch \
+ "
SRCREV = "2768251dacce3939136c839aeca413f4aa4241d0"
PV = "1.6.1"
S = "${WORKDIR}/git"
-do_configure_append() {
+do_configure:append() {
# autogen uses python2 so generate headers ourselves
cd ${S}
python3 generate.py mypaint-brush-settings-gen.h brushsettings-gen.h
diff --git a/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb b/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
index 4ecc2fef8b..ca3912da88 100644
--- a/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
+++ b/meta-gnome/recipes-gimp/mypaint/mypaint-brushes-1.0_git.bb
@@ -9,4 +9,4 @@ SRCREV = "8a0124ac0675103eae8fa41fad533851768ae1ce"
PV = "1.3.1"
S = "${WORKDIR}/git"
-FILES_${PN} += "${datadir}/mypaint-data"
+FILES:${PN} += "${datadir}/mypaint-data"