aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyzmq
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyzmq')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
new file mode 100644
index 0000000000..61aeaca5fa
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyzmq/club-rpath-out.patch
@@ -0,0 +1,29 @@
+From efae4e08d13e0958d929ea524e21c0a210b31982 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Fri, 22 Jan 2021 11:41:12 +0200
+Subject: [PATCH] setup.py: Adjust _add_rpath
+
+Fix error: unrecognized command-line option '-R'
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+
+---
+ setup.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index b634d94..7f6a2f1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -235,9 +235,6 @@ def _add_rpath(settings, path):
+ """
+ if sys.platform == 'darwin':
+ settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path])
+- else:
+- settings['runtime_library_dirs'].append(path)
+-
+
+ def settings_from_prefix(prefix=None):
+ """load appropriate library/include settings from ZMQ prefix"""