aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb b/meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb
new file mode 100644
index 0000000000..80fe945552
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xmodem_0.4.7.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "XMODEM protocol implementation"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI[sha256sum] = "2f1068aa8676f0d1d112498b5786c4f8ea4f89d8f25d07d3a0f293cd21db1c35"
+
+inherit pypi setuptools3
+
+do_install:append() {
+ install -d ${D}${docdir}/${PN}
+ mv ${D}/usr/doc/* ${D}${docdir}/${PN}/
+ rmdir ${D}/usr/doc
+}
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-logging \
+"
+BBCLASSEXTEND = "native nativesdk"