aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-24 08:25:35 +0800
committerKhem Raj <raj.khem@gmail.com>2023-03-23 21:46:12 -0700
commit044a4e0fe38620a0e31392db876a2d6ca8756bfa (patch)
tree9a3ecdfe16a210cbd92cb04462b4bbd45752e6f3
parent68faf0807683e8663c8060eb3b065d42b0405c33 (diff)
downloadmeta-openembedded-044a4e0fe38620a0e31392db876a2d6ca8756bfa.tar.gz
libcompress-raw-zlib-perl: upgrade 2.202 -> 2.204
Changelog: ========== * Update zlib sources to zlib-1.2.13 https://github.com/pmqs/Compress-Raw-Zlib/issues/20 eafe29c85437582d16c6bda16449ea2dea534266 * Use GIMME_V instead of the deprecated GIMME https://github.com/pmqs/Compress-Raw-Zlib/pull/19 7a7b045d9d8729a6c82a78039dab5decf7e65907 License-Update: Copyright year updated to 2023. zlib version updated to 1.2.13, Copyright year updated to 2022. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.202.bb47
-rw-r--r--meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.204.bb28
2 files changed, 28 insertions, 47 deletions
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.202.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.202.bb
deleted file mode 100644
index 5459572e2b..0000000000
--- a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.202.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
-# The following is the difference between the old and the new license text.
-# Please update the LICENSE value if needed, and summarize the changes in
-# the commit message via 'License-Update:' tag.
-# (example: 'License-Update: copyright years updated.')
-#
-# The changes:
-#
-# --- README
-# +++ README
-# @@ -1,4 +1,4 @@
-# - Copyright (c) 2005-2020 Paul Marquess. All rights reserved.
-# + Copyright (c) 2005-2022 Paul Marquess. All rights reserved.
-# This program is free software; you can redistribute it
-# and/or modify it under the same terms as Perl itself.
-#
-#
-#
-
-SUMMARY = "Perl interface to the zlib compression library."
-DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
-to the zlib compression library (see 'AUTHOR' for details about where to \
-get zlib)."
-HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
-SECTION = "libs"
-LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
-
-LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=9bd174bdd6fbb141c1b679e2466e0b39"
-
-SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
-
-SRC_URI[sha256sum] = "96e20946eb457a32d2d7a0050b922e37b5ada41246bcdc824196d3f7c4da91b7"
-
-DEPENDS += "zlib"
-
-S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
-
-inherit cpan
-
-export BUILD_ZLIB="0"
-
-do_compile() {
- export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
- cpan_do_compile
-}
-
-BBCLASSEXTEND = "native"
diff --git a/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.204.bb b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.204.bb
new file mode 100644
index 0000000000..e0aa2e9c25
--- /dev/null
+++ b/meta-perl/recipes-perl/libcompress/libcompress-raw-zlib-perl_2.204.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Perl interface to the zlib compression library."
+DESCRIPTION = "The Compress::Raw::Zlib module provides a Perl interface \
+to the zlib compression library (see 'AUTHOR' for details about where to \
+get zlib)."
+HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Zlib"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://README;beginline=8;endline=17;md5=45bba5fa4937353fd4f505fa2108a6bf"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Zlib-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "f161f4297efadbed79c8b096a75951784fc5ccd3170bd32866a19e5c6876d13f"
+
+DEPENDS += "zlib"
+
+S = "${WORKDIR}/Compress-Raw-Zlib-${PV}"
+
+inherit cpan
+
+export BUILD_ZLIB="0"
+
+do_compile() {
+ export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
+ cpan_do_compile
+}
+
+BBCLASSEXTEND = "native"