aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-02-12 11:07:53 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-19 10:09:59 +0100
commiteaa248e369b5445e41e895e6894d6e2a47c917a2 (patch)
tree6e889faab113da9fa72c2399bce438c93876e35b /meta-gnome
parentd2d6fa93dda0f2a1ac6334b2e7f22bbe092881e4 (diff)
downloadmeta-openembedded-eaa248e369b5445e41e895e6894d6e2a47c917a2.tar.gz
gnome-bluetooth: fix build by using a valid dbus interface + unblacklist
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch122
-rw-r--r--meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb8
2 files changed, 126 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch
new file mode 100644
index 0000000000..99049a0cab
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch
@@ -0,0 +1,122 @@
+From 1555f85b222db0d536efe277d31b57b2a8b938f4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Thu, 12 Feb 2015 01:19:41 +0100
+Subject: [PATCH] bluetooth-client: use valid interface names
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate[version unmaintained upstream]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ lib/bluetooth-client.c | 12 ++++++------
+ lib/bluetooth-client.xml | 6 +++---
+ lib/test-agent.c | 2 +-
+ 3 files changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/lib/bluetooth-client.c b/lib/bluetooth-client.c
+index d62d56d..02e194c 100644
+--- a/lib/bluetooth-client.c
++++ b/lib/bluetooth-client.c
+@@ -721,7 +721,7 @@ static void add_device(DBusGProxy *adapter, GtkTreeIter *parent,
+ BLUEZ_DEVICE_INTERFACE, path);
+
+ if (device != NULL)
+- device_get_properties(device, &hash, NULL);
++ org_bluez_device_get_properties(device, &hash, NULL);
+ } else
+ device = NULL;
+
+@@ -945,7 +945,7 @@ static void adapter_added(DBusGProxy *manager,
+ adapter = dbus_g_proxy_new_from_proxy(manager,
+ BLUEZ_ADAPTER_INTERFACE, path);
+
+- adapter_get_properties(adapter, &hash, NULL);
++ org_bluez_adapter_get_properties(adapter, &hash, NULL);
+ if (hash != NULL) {
+ value = g_hash_table_lookup(hash, "Address");
+ address = value ? g_value_get_string(value) : NULL;
+@@ -1178,7 +1178,7 @@ static void bluetooth_client_init(BluetoothClient *client)
+ dbus_g_proxy_connect_signal(priv->manager, "DefaultAdapterChanged",
+ G_CALLBACK(default_adapter_changed), client, NULL);
+
+- manager_list_adapters(priv->manager, &array, NULL);
++ org_bluez_manager_list_adapters(priv->manager, &array, NULL);
+ if (array != NULL) {
+ int i;
+
+@@ -1189,7 +1189,7 @@ static void bluetooth_client_init(BluetoothClient *client)
+ }
+ }
+
+- manager_default_adapter(priv->manager, &default_path, NULL);
++ org_bluez_manager_default_adapter(priv->manager, &default_path, NULL);
+ if (default_path != NULL) {
+ default_adapter_changed(priv->manager, default_path, client);
+ g_free(default_path);
+@@ -1541,7 +1541,7 @@ gboolean bluetooth_client_start_discovery(BluetoothClient *client)
+ if (adapter == NULL)
+ return FALSE;
+
+- adapter_start_discovery(adapter, NULL);
++ org_bluez_adapter_start_discovery(adapter, NULL);
+
+ g_object_unref(adapter);
+
+@@ -1568,7 +1568,7 @@ gboolean bluetooth_client_stop_discovery(BluetoothClient *client)
+ if (adapter == NULL)
+ return FALSE;
+
+- adapter_stop_discovery(adapter, NULL);
++ org_bluez_adapter_stop_discovery(adapter, NULL);
+
+ g_object_unref(adapter);
+
+diff --git a/lib/bluetooth-client.xml b/lib/bluetooth-client.xml
+index 2326277..38c7fb0 100644
+--- a/lib/bluetooth-client.xml
++++ b/lib/bluetooth-client.xml
+@@ -1,7 +1,7 @@
+ <?xml version="1.0" encoding="UTF-8" ?>
+
+ <node name="/">
+- <interface name="manager">
++ <interface name="org.bluez.manager">
+ <method name="DefaultAdapter">
+ <arg type="o" direction="out"/>
+ </method>
+@@ -16,7 +16,7 @@
+ </method>
+ </interface>
+
+- <interface name="adapter">
++ <interface name="org.bluez.adapter">
+ <method name="GetProperties">
+ <arg type="a{sv}" direction="out"/>
+ </method>
+@@ -44,7 +44,7 @@
+ </method>
+ </interface>
+
+- <interface name="device">
++ <interface name="org.bluez.device">
+ <method name="GetProperties">
+ <arg type="a{sv}" direction="out"/>
+ </method>
+diff --git a/lib/test-agent.c b/lib/test-agent.c
+index 8d60da6..83464eb 100644
+--- a/lib/test-agent.c
++++ b/lib/test-agent.c
+@@ -40,7 +40,7 @@ static gboolean agent_pincode(DBusGMethodInvocation *context,
+ GValue *value;
+ const gchar *address, *name;
+
+- device_get_properties(device, &hash, NULL);
++ org_bluez_device_get_properties(device, &hash, NULL);
+
+ if (hash != NULL) {
+ value = g_hash_table_lookup(hash, "Address");
+--
+1.9.3
+
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
index b9b73551d6..8711b8af0b 100644
--- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
+++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb
@@ -6,15 +6,15 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
PR = "r1"
-PNBLACKLIST[gnome-bluetooth] ?= "dbus-binding-tool fails with: Unable to load gnome-bluetooth-2.32.0/lib/bluetooth-client.xml": "manager" is not a valid D-Bus interface name"
-
SECTION = "x11/gnome"
DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib libunique libnotify bluez4 gnome-keyring virtual/libx11 libxi intltool-native"
inherit gnomebase gtk-icon-cache
-SRC_URI += "file://0001-bluetooth-input-Fix-compile-errors.patch \
- "
+SRC_URI += " \
+ file://0001-bluetooth-input-Fix-compile-errors.patch \
+ file://0002-bluetooth-client-use-valid-interface-names.patch \
+"
SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae"
SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973"