aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/mbedtls
diff options
context:
space:
mode:
authorRicardo Simoes <ricardo.simoes@pt.bosch.com>2024-05-02 14:17:58 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-02 07:32:55 -0700
commit577a55f7a522c1df519dd04cacc42a6f57cee177 (patch)
tree75e643d8c631b43b8533f4ac0e70a660235a0c0e /meta-networking/recipes-connectivity/mbedtls
parent492b1b1adc1c546efd10b659d220a810736cc04a (diff)
downloadmeta-openembedded-577a55f7a522c1df519dd04cacc42a6f57cee177.tar.gz
mbedtls: Fix warning for missing program
When PACKAGECONFIG does not contains 'programs', the hello binary will not be generated, but the ALTERNATIVE 'hello' is still set, causing the update-alternatives bbclass to generate warnings for the missing 'hello' binary. This commit fixes that by only populating ALTERNATIVES when 'programs' is enabled. Signed-off-by: Ricardo Simoes <ricardo.simoes@pt.bosch.com> Signed-off-by: Mark Jonas <mark.jonas@de.bosch.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb2
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
index 301e655989..db79241f2a 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.8.bb
@@ -50,7 +50,7 @@ RPROVIDES:${PN} = "polarssl"
PACKAGES =+ "${PN}-programs"
FILES:${PN}-programs = "${bindir}/"
-ALTERNATIVE:${PN}-programs = "hello"
+ALTERNATIVE:${PN}-programs = "${@bb.utils.contains('PACKAGECONFIG', 'programs', 'hello', '', d)}"
ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
index 92a2de82a3..a10fce0ffc 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.0.bb
@@ -55,7 +55,7 @@ RPROVIDES:${PN} = "polarssl"
PACKAGES =+ "${PN}-programs"
FILES:${PN}-programs = "${bindir}/"
-ALTERNATIVE:${PN}-programs = "hello"
+ALTERNATIVE:${PN}-programs = "${@bb.utils.contains('PACKAGECONFIG', 'programs', 'hello', '', d)}"
ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
BBCLASSEXTEND = "native nativesdk"