aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/mbedtls
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2023-02-25 23:17:17 +0000
committerKhem Raj <raj.khem@gmail.com>2023-02-26 00:17:45 -0800
commite012fe075d6de6050e1a37d23bfbb70b5278f0a5 (patch)
tree7949da17a5dc7fd777ffe14b9225860ef62ecd37 /meta-networking/recipes-connectivity/mbedtls
parent3b2330e4ee778c8a213116e927532dca5b36338b (diff)
downloadmeta-openembedded-e012fe075d6de6050e1a37d23bfbb70b5278f0a5.tar.gz
mbedtls: set up /usr/bin/hello as alternative
As mbedtls installs this rather generically-named /usr/bin/hello binary, it conflicts with the one provided by lmbench, hence set it up as an alternative to avoid conflicts when both are installed to rootfs or SDK. Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
index f5f1236f18..e19587ca01 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
SRCREV = "89f040a5c938985c5f30728baed21e49d0846a53"
SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=mbedtls-2.28"
-inherit cmake
+inherit cmake update-alternatives
PACKAGECONFIG ??= "shared-libs programs"
PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
@@ -47,6 +47,9 @@ RPROVIDES:${PN} = "polarssl"
PACKAGES =+ "${PN}-programs"
FILES:${PN}-programs = "${bindir}/"
+ALTERNATIVE:${PN}-programs = "hello"
+ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
+
BBCLASSEXTEND = "native nativesdk"
CVE_PRODUCT = "mbed_tls"