aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/squid
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-02 17:14:48 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-03 11:08:29 -0800
commitc481ee79a2695e039996668fb96ecfa906897a2a (patch)
tree349f5621eaecf180080123acc294ad4c42e9c9e4 /meta-networking/recipes-daemons/squid
parentfa0ef82344b8295040aa3fb49c8ec8da86b7ad07 (diff)
downloadmeta-openembedded-c481ee79a2695e039996668fb96ecfa906897a2a.tar.gz
squid: Include <limits> for using std::numeric_limits
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/squid')
-rw-r--r--meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch105
-rw-r--r--meta-networking/recipes-daemons/squid/squid_4.14.bb (renamed from meta-networking/recipes-daemons/squid/squid_4.13.bb)6
2 files changed, 108 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch b/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch
new file mode 100644
index 0000000000..28a410c26f
--- /dev/null
+++ b/meta-networking/recipes-daemons/squid/files/0001-Fix-build-on-Fedora-Rawhide-772.patch
@@ -0,0 +1,105 @@
+From 1f8b5f0e1cc27634a7310be4c9674112f919d974 Mon Sep 17 00:00:00 2001
+From: uhliarik <luhliari@redhat.com>
+Date: Thu, 18 Feb 2021 01:08:40 +0000
+Subject: [PATCH] Fix build on Fedora Rawhide (#772)
+
+* add SYSTEMD_LIBS to all binaries using client_side.cc, fixing linking
+* add `<limits>` to all sources using std::numeric_limits, fixing gcc-11
+ builds
+---
+Upstream-Status: Backport [https://github.com/kraj/squid/commit/1f8b5f0e1cc27634a7310be4c9674112f919d974]
+ src/Makefile.am | 4 ++++
+ src/ip/QosConfig.cc | 1 +
+ src/ipc/mem/PageStack.cc | 1 +
+ src/proxyp/Parser.cc | 1 +
+ src/security/ServerOptions.cc | 2 ++
+ src/ssl/helper.cc | 2 ++
+ 6 files changed, 11 insertions(+)
+
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2320,6 +2320,7 @@ tests_test_http_range_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_test_http_range_LDFLAGS = $(LIBADD_DL)
+@@ -2624,6 +2625,7 @@ tests_testHttpRequest_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testHttpRequest_LDFLAGS = $(LIBADD_DL)
+@@ -3487,6 +3489,7 @@ tests_testURL_LDADD = \
+ $(SSLLIB) \
+ $(KRB5LIBS) \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testURL_LDFLAGS = $(LIBADD_DL)
+@@ -3646,6 +3649,7 @@ nodist_tests_testYesNoNone_SOURCES = \
+ tests_testYesNoNone_LDADD= \
+ base/libbase.la \
+ $(LIBCPPUNIT_LIBS) \
++ $(SYSTEMD_LIBS) \
+ $(COMPAT_LIB) \
+ $(XTRA_LIBS)
+ tests_testYesNoNone_LDFLAGS = $(LIBADD_DL)
+--- a/src/ip/QosConfig.cc
++++ b/src/ip/QosConfig.cc
+@@ -21,6 +21,7 @@
+ #include "Parsing.h"
+
+ #include <cerrno>
++#include <limits>
+
+ CBDATA_CLASS_INIT(acl_tos);
+
+--- a/src/ipc/mem/PageStack.cc
++++ b/src/ipc/mem/PageStack.cc
+@@ -14,6 +14,7 @@
+ #include "Debug.h"
+ #include "ipc/mem/Page.h"
+ #include "ipc/mem/PageStack.h"
++#include <limits>
+
+ /// used to mark a stack slot available for storing free page offsets
+ const Ipc::Mem::PageStack::Value Writable = 0;
+--- a/src/security/ServerOptions.cc
++++ b/src/security/ServerOptions.cc
+@@ -24,6 +24,8 @@
+ #endif
+ #endif
+
++#include <limits>
++
+ Security::ServerOptions &
+ Security::ServerOptions::operator =(const Security::ServerOptions &old) {
+ if (this != &old) {
+--- a/src/ssl/helper.cc
++++ b/src/ssl/helper.cc
+@@ -19,6 +19,8 @@
+ #include "ssl/helper.h"
+ #include "wordlist.h"
+
++#include <limits>
++
+ Ssl::CertValidationHelper::LruCache *Ssl::CertValidationHelper::HelperCache = nullptr;
+
+ #if USE_SSL_CRTD
+--- a/src/acl/ConnMark.cc
++++ b/src/acl/ConnMark.cc
+@@ -16,6 +16,8 @@
+ #include "http/Stream.h"
+ #include "sbuf/Stream.h"
+
++#include <limits>
++
+ bool
+ Acl::ConnMark::empty() const
+ {
diff --git a/meta-networking/recipes-daemons/squid/squid_4.13.bb b/meta-networking/recipes-daemons/squid/squid_4.14.bb
index 873d09344d..6d154c87e0 100644
--- a/meta-networking/recipes-daemons/squid/squid_4.13.bb
+++ b/meta-networking/recipes-daemons/squid/squid_4.14.bb
@@ -24,15 +24,15 @@ SRC_URI = "http://www.squid-cache.org/Versions/v${MAJ_VER}/${BPN}-${PV}.tar.bz2
file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
file://0001-tools.cc-fixed-unused-result-warning.patch \
file://0001-splay.cc-fix-bind-is-not-a-member-of-std.patch \
+ file://0001-Fix-build-on-Fedora-Rawhide-772.patch \
"
SRC_URI_remove_toolchain-clang = "file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch"
-SRC_URI[md5sum] = "31e524a416715d6bfef30e072d2ca076"
-SRC_URI[sha256sum] = "d09d3c31e3a7d158bda75501e763bd1cd3c3a99f5af6781ec1fd30eed2f771ed"
+SRC_URI[sha256sum] = "4ad08884f065f8e1dac166aa13db6a872cde419a1717dff4c82c2c5337ee5756"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://errors/COPYRIGHT;md5=4c3268f394af77fbbf541875cef96a6c \
+ file://errors/COPYRIGHT;md5=0e03cd976052c45697ad5d96e7dff8dc \
"
DEPENDS = "libtool krb5 openldap db cyrus-sasl"