aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch
diff options
context:
space:
mode:
authorSakib Sajal <sakib.sajal@windriver.com>2022-04-06 12:35:57 -0400
committerKhem Raj <raj.khem@gmail.com>2022-04-10 10:05:35 -0700
commitae60e9869b3ff1425dca70195b19cc24f06e722c (patch)
treee9661e4429dfe1a20e40b3d73cbde1d547bd4019 /meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch
parent6305aacfded18abba92424ad974ccaf704998924 (diff)
downloadmeta-openembedded-ae60e9869b3ff1425dca70195b19cc24f06e722c.tar.gz
drbd-utils: update 9.13.1 -> 9.20.2
Dropped patch which is merged upstream: 0001-v84-Make-setup_options-definitions-as-extern.patch Refreshed patch: 0001-drbd-utils-support-usrmerge.patch The compiled binaries are not linked to LDFLAGS options provided by the build system cause QA issue: do_package_qa: QA Issue: File /usr/sbin/drbdmon in package drbd-utils doesn't have GNU_HASH (didn't pass LDFLAGS?) Add LDFLAGS when linking drmdmon binary. Suppress new Clang warning -Wdefaulted-function-deleted and -Wunused-private-field Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch
new file mode 100644
index 0000000000..354be0ff18
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-drbdmon-add-LDFLAGS-when-linking.patch
@@ -0,0 +1,29 @@
+From a61b9ff2d2cb7387a5cd347b2201535ee45a46ee Mon Sep 17 00:00:00 2001
+From: Sakib Sajal <sakib.sajal@windriver.com>
+Date: Thu, 31 Mar 2022 15:09:58 -0400
+Subject: [PATCH] drbdmon: add LDFLAGS when linking
+
+Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
+---
+ user/drbdmon/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/user/drbdmon/Makefile.in
++++ b/user/drbdmon/Makefile.in
+@@ -1,6 +1,6 @@
+ CXXFLAGS=-std=c++11 -I. -I../shared -Icppdsaext/src -Wall -Werror -pedantic-errors -fPIC -O2 \
+ -Wsign-compare -Wpointer-arith -Wswitch-default -Wswitch-enum -Wtype-limits \
+--Wmissing-declarations -Wshadow
++-Wmissing-declarations -Wshadow -Wno-defaulted-function-deleted -Wno-unused-private-field
+ CXX = @CXX@
+ LIBS = @LIBS@
+
+@@ -51,7 +51,7 @@ $(dsaext-obj): $(basename $(dsaext-obj))
+ $(integerparse-obj): $(basename $(integerparse-obj)).cpp $(basename $(integerparse-obj)).h
+
+ drbdmon: $(ls-obj)
+- $(CXX) -o $@ $(CPPFLAGS) $(CXXFLAGS) $^ $(LIBS)
++ $(CXX) -o $@ $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS)
+
+ # do not try to rebuild Makefile itself
+ Makefile: ;