aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2016-08-04 09:54:19 +0200
committerJoe MacDonald <joe_macdonald@mentor.com>2016-08-05 09:13:18 -0400
commitbc8fd52a5c0fa4125e6f8137056988cae9332b6c (patch)
tree895b3e512c6d7fddd50d65062b2cc1697c7fac32 /meta-networking
parent32a6fd48ab781c15c37551f4e8ed6721ca5cb87b (diff)
downloadmeta-openembedded-bc8fd52a5c0fa4125e6f8137056988cae9332b6c.tar.gz
ntp: make ntp and alternative for ntpd
This way ntp can be used as an alternative to ntpd from busybox Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
index 5f60441384..bca5a07458 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
@@ -126,7 +126,7 @@ RCONFLICTS_ntpdate += "ntpdate-systemd"
RSUGGESTS_${PN} = "iana-etc"
-FILES_${PN} = "${sbindir}/ntpd ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \
+FILES_${PN} = "${sbindir}/ntpd.ntp ${sysconfdir}/ntp.conf ${sysconfdir}/init.d/ntpd ${libdir} \
${NTP_USER_HOME} \
${systemd_unitdir}/ntp-units.d/60-ntpd.list ${libexecdir}\
"
@@ -159,3 +159,9 @@ pkg_postinst_ntpdate() {
fi
}
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "ntpd"
+ALTERNATIVE_LINK_NAME[ntpd] = "${sbindir}/ntpd"