aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorMatt Hoosier <matt.hoosier@garmin.com>2020-07-16 09:34:41 -0500
committerKhem Raj <raj.khem@gmail.com>2020-07-16 09:53:26 -0700
commit482cb703fafe505b1c64832eb2bec275eeb4d0e5 (patch)
tree203c3cfd41b0bf9bfe583dc87e6b7688a38c0454 /meta-oe/recipes-benchmark
parenta5449a234a08d09ceb2dcd3c3773b1aca6bf5549 (diff)
downloadmeta-openembedded-482cb703fafe505b1c64832eb2bec275eeb4d0e5.tar.gz
glmark2: don't build full OpenGL backends by default
Most embedded GPU's implementations OpenGL include only the OpenGL ES APIs. Attempting to compile the {x11,wayland,drm}-gl variants of GLMark fail in those cases. Signed-off-by: Matt Hoosier <matt.hoosier@garmin.com> Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 6d20bbdaf1..82821ad63d 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -24,9 +24,9 @@ inherit waf pkgconfig features_check
REQUIRED_DISTRO_FEATURES += "opengl"
-PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
- drm-gl drm-gles2"
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gles2', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gles2', '', d)} \
+ drm-gles2"
PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"